reTerminal: Did your screen work out the box?

Hi all,

Just received my reTerminal today, was excited to power it on as I want to use it in a YouTube tutorial series for cross compiling Qt Apps; however, when I powered it on nothing displayed on screen. I see the power and sys lights light up and possibly the lcd backlight but no image displayed. I hooked it up via ethernet and was able to confirm the system is indeed powering on and I am able to SSH in and run commands. Found the wiki and was able to clone the repo and run the reTerminal script, but after reboot still no luck with screen. I opened up the housing and the flex ribbon cable seems to be intact and connected/seated properly. Any ideas?

Mine worked out of the box, and even after I did some OS updates and reimaged to 64-bit. After the 64-bit reimage the display wouldn’t come on initially, so I connected it to an external HDMI monitor for its first boot - not sure if that made a difference, because I’m pretty sure I just didn’t wait long enough the first time. It does take quite a while for the LCD to init.

Then I made the mistake of following the instructions to update the STM32G030F6 on the board to the latest firmware, and now the chip won’t enumerate over SWD or I2C anymore. Think I’ve blown a fuse or something… sigh…

The lack of external access to the MCU’s SWD pins is a nightmare - the test points are in literally the worst possible position they could be in, you have to take the entire thing apart to get at them - and despite being a very recently produced unit (I had it on backorder from Mouser about a month and a half ago and it only showed up this week) it still came with MCU firmware 1.0.

I shouldn’t have upgraded it… I’m honestly really disappointed with Seeed’s documentation on this thing. There’s schematics, and they list testpoint numbers, but they don’t show the obvious JTAG header at all, and there are no labels whatsoever on any of the testpoints or components on the board other than the big labels for the camera connectors etc…

I honestly kind of regret buying this now. I had a few different ideas for things I could do with it, but the software setup is confusing, as I’ve mentioned the hardware documentation is sorely lacking, and I’ve had it for like 4 days and it’s already broken through (to the best of my knowledge) no fault of my own.

Dear neggless,

I am on the same wave - the unit workes out the box, but after the STM32 upgrade I lost the display and I2C are not available any more. Did you find any solution?