reTerminal - Boot from SD?

I have followed the instructions from the FAQ and getting started guides to flash a non-SEEED OS image to a micro-SD card, but cannot get the board to boot. I’m not sure if it’s an issue with the image (and maybe missing drivers) or an issue with the board.

I’ve inserted the SD card and tried rebooting with the boot toggle switch in both positions. With the toggle “up” it boots from the eMMC. With the toggle “down”, it just sits idle with a blank screen. Tried connecting to ethernet in case it was just a case of screen drivers, but it never shows up on the network.

Seems like others are having issues using a generic image flashed to the eMMC, although in theory I think that is supposed to work as well. Anyone else have any luck?

Cheers,
Corey

Hello @Corey_Smart,

I will offer you further guidance in this matter. First of all, if you are using the CM4 eMMC version on the reTerminal, you cannot use SD cards. This is because the eMMC is internally connected to the SD card interface. It is also mentioned in the official Raspberry Pi documentation. You can check the section Flashing the Compute Module eMMC in the above document and it mentions there. When you flash OS to SD card, it won’t boot from the SD card because it will only prioritize the eMMC and only boot from eMMC.

However, if you want to boot the OS from an SD card, you need to use a CM4 module without the eMMC onboard. This way reTerminal will directly boot from SD card.

Also, I saw that you mentioned about non-SEEED OS image. Could you flash this on to the eMMC of the reTerminal and let me know? Please use this guide to flash the OS.

Can I know which OS you are trying to flash?

Best Regards,
Lakshantha