reTerminal and bullseye?

Does the reTerminal support the latest Raspian OS (bullseye)? If so, if order one, will it come preinstalled with bullseye?

Hello, the current pre-installed system of reTerminal is 2021-09-14-Raspbian(modified)-32-bit. If you need the latest version of the system, you need to install it by yourself after receiving the goods. Tutorial reference:

@pgerken
I attempted to flash bullseye on a reTerminal. The screen orientation was portrait instead of landscape and the mouse was not functioning correctly. @lakshan has said these are both known issues that are being worked on and will soon be solved. He expects a bullseye release of the software is round the corner

Hi @dq11,

The issues have been fixed temporarily for the time being. Please check this:

Thank you.

@lakshan
I was hoping for a more streamlined bullseye install but I managed to follow the steps outlined in the japanese site and got the sensor demo app working and the screen fixed to horizontal

Now the annoyance is the touch mouse is acting up weird and has a mind of its own and does not track where i want it to click. Any fixes for the mouse tracking to make it as good as buster ?

Hello @dq11,

I will investigate this issue and get back to you.

Hello @dq11,

You need to add the following line inside /boot/config.txt file:

dtoverlay=reTerminal,tp_rotate=1

Note: “dtoverlay=reTerminal” is already inside the above file by default. So you just need to add “,tp_rotate=1” after “dtoverlay=reTerminal”.

And then reboot. The touch will start to work as normal again.

The mouse moves but it is not very effective and useable compared to buster

pi@reterm67:~ $ cat /boot/config.txt 
# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]

[pi4]
# Run as fast as firmware / board allows
arm_boost=1

[all]
enable_uart=1
dtoverlay=dwc2,dr_mode=host
dtparam=ant2
disable_splash=1
ignore_lcd=1
dtoverlay=vc4-kms-v3d-pi4
dtoverlay=i2c3,pins_4_5
gpio=13=pu
#dtoverlay=reTerminal
dtoverlay=reTerminal,tp_rotate=1
#dtoverlay=reTerminal-bridge

Hi @dq11,

Could you please record a video and share the mouse behavior? For me, it works as normal.

Thank you.

rec.zip (3.2 MB)

@lakshan I have uploaded a recording of the funky mouse behavior and how it draws rectangles and how imprecise and unusable it is and does not go where i want it to go.

Hello @dq11,

Thank you for the video. Could you please delete tp_rotate=1 from /boot/config.txt file, reboot reTerminal and try again?

Thank you.

Hello @lakshan
The mouse tracks much better without the tp_rotate=1
I still have those rectangle bounding boxes being highlighted in gray when i move around with the mouse as seen in the recording that i attached previously.
Any suggestions for how to get rid of that behavior ?

Hello @dq11,

I am not sure how to get rid of those bounding boxes. Is that affecting the overall usage of the reTerminal?

Thank you.

@lakshan
For example i cannot use the touch screen mouse effectively to launch the reTerminal demo app that is on the desktop. I have to resort to launching the app remotely using vnc

Hello @dq11,

The behavior on your reTerminal is quite strange because I did not encounter the issue that you mentioned on my reTerminal. I will try to get another reTerminal to test this and keep you updated.

When you tested before, the mouse worked perfectly with Buster right?

Just received my reTerminal and noticed that if I “lightly” touch the screen, it behaves as expected and moves the cursor. If I push “slightly” harder on the screen, then the bounding box shows up.

@dq11 Try to not push “too” hard on the screen and see if it behaves as expected.

Playing with my reTerminal, the bounding boxes described seem to be simply a drag select. On a single tap, this would indicate (to me) some jitter in the touch screen positioning. Unlikely to be caused by an os update?

Anyway, is there an official image of bullseye for the reTerminal yet?

Hello,

There is no official image from Seeed yet. Will update in this discussion if we release one.

The only way to get it on the reTerminal is to first install the Raspberry Pi Bullseye image and then run this script:

Hope it helps.

Sorry for the newby misunderstandings, I finally figured out what you actually said (which is quite sensible but beyond my initial understanding).

Near as I can tell using diff tools this script is now what is being supplied with the downloadable tools for installing reTerminal drivers.

As near as I can tell, what would really be done in this situation (simplifying step-by-step):
Install the Bullseye image using the procedure here: [Getting Started with reTerminal - Seeed Wiki (seeedstudio.com)](Getting Started with reTerminal - Seeed Wiki)

Once this boots up the reTerminal has serious issues, like a black screen. But if the procedure was followed properly you can SSH into it from another computer and follow the procedure here: https://wiki.seeedstudio.com/reTerminal/#install-reterminal-drivers-after-flashing-new-raspberry-pi-os-ubuntu-os-or-other-os

This includes the new script as shown above. The screen now works as long as you remember to find out which port expander you have and add the line to the startup script if you have the old chip.

But the unit is still unusable. With an external mouse you can click on links etc. if you attack the left click button with extreme ferocity. Ordinary clicks are ignored. No clicks work on the touch screen. An external monitor is no longer useable. Orientation is wrong (portrait) until you physically rotate the unit up. Back to Buster for me using https://wiki.seeedstudio.com/reTerminal-FAQ/#q2-how-can-i-flash-raspberry-pi-os-which-is-originally-shipped-with-reterminal

Hi @dq11,

I had a similar issue and replaced the line:

dtoverlay=reTerminal,tp_rotate=1

with

dtoverlay=reTerminal,tp_rotate=0

and now works perfect.
Cheers,
b.