Respeaker v2 disable audio out

Hi I was wondering if there is a way to disable the audio out portion of the Respeaker so that it only behaves as a USB audio-in (maybe firmware)?

So if I was to plug it in to Linux/Win/Mac/Android the audio out option wouldn’t even show up as available.

Thanks for any help.

Hi there,

It is related with firmware, here is the firmware for the mics only. thanks.

<LINK_TEXT text=“ … t_i1o0.bin”></LINK_TEXT>

Thanks it worked perfectly!

My use is a USB mic on Android TV (Nvidia Shield-Logitech Harmony remote), but with the regular ReSpeaker firmware USB audio out is the default device on Shield (not HDMI) with no real way of changing it (without root access - and editing audio_policy.conf).

With this test_i1o0.bin firmware HDMI is active (for HD audio passthrough) and the ReSpeaker v2.0 is a great farfield mic that can be used for voice searching.

I’m interested in the mic-only firmware because it enables high quality audio output and side steps the noise issue,

<URL url=" text=“viewtopic.php?f=87&t=8259#p27891”>
But I guess a drawback is incapable of AEC.

Is it right?

Hi there,

The issue(viewtopic.php?f=87&t=8259#p27891) is not related with AEC function. We are looking at the issue and see something induced the I2S abnormal. We will update the status on viewtopic.php?f=87&t=8259#p27891 page. thanks.

I just want to know whether AEC can be enabled when the mic-only firmware test_i1o0.bin is installed.

Also I naturally expect to avoid the noise issue by disabling audio output from the mic-array.

Will this firmware work on the new 2.1/ReSpeaker USB version as well? Just ordered the new:

<LINK_TEXT text=“ … -4247.html”></LINK_TEXT>

If not could you make another firmware with the audio out totally disabled?

Thanks Bill!