ReSpeaker USB Mic Array Firmware reset

Hello everyone, I apologise if this question has been asked before but I really tried to search but to no avail.

I have a ReSpeaker USB Mic Array and I think I have made a mistake when updating the DFU since I have used this script (GitHub - respeaker/mic_array_dfu: ReSpeaker Microphone Array DFU tool for firmware upgrade) to flash the device which lead the name and the vendor code to change from 0x0018 to 0x0007 and it made all the scripts from GitHub - respeaker/usb_4_mic_array: ReSpeaker 4 Mic Array with builtin VAD, DOA, AEC, Beamforming & NS) stop working.

I tried to reset to factory using sudo python3 dfu --revertfactory but it does not detect the new vendorID and if I change the vendorID in the scripts to 0x0007, the script runs however it does not update the firmware.

So my question is, how can I just revert my usb Mic Array to factory settings.

here what i have when I use lsusb

Bus 003 Device 030: ID 2886:0007 Seeed Technology Co., Ltd. ReSpeaker Microphone Array

Thank you in advance.