ReSpeaker Mic Array V2.0 AEC not working

Hello,



I’ve just tried using the ReSpeaker Mic Array V2.0 as per the “Out of Box Demo”.



I was expecting results similar to advertised on the ReSpeaker Mic Array V2.0 product page, with channel 0 begin AEC filtered audio.



Instead, all the channels sound very similar with barley any filtering being obvious. Channel 0 definitely shows a larger amplitude, but for ALL captured sound, not just voice. Please see the attached picture as an example, and to show the Audacity settings.



How can I get the same results as posted on the ReSpeaker Mic Array V2.0 as per the “Out of Box Demo”?
Screen Shot 2019-12-18 at 12.29.16 pm.jpg

Hi there

maybe you can use Audacity 2.3.0 to solve your probelm :smiley:.the environment is WIN10 when I succeed. :smiley:

Hello,



I’m using Audacity 2.3.2 on a Mac Mojave 10.14.6.



Audacity 2.3 is better somehow?

Hi,



did you tried Audacity 2.3.0?

Yes I have tried with Audacity 2.3.0 and 2.3.2.



Same result. How do I get the same results as advertised on your product page?

My results are still not very impressive. The AEC definitely is not functioning as demonstrated. Channel 0 seems to show no sign of filtering. All channels ultimately sound exactly the same, with channel 0 just being louder. The VAD also triggers on any sound, not just voice. I’ve tried tuning with GAMMAVAD_SR and found this only alters the threshold for any sound.



I’ve tried both Audacity 2.3.0 and 2.3.2.



I’ve successfully reloaded the 6_channels_firmware.bin just to be sure the correct firmware was installed.



Attached is another screen shot of an Audacity example. The Mic Array is roughly 50cm from music being played on a laptop, and 70cm from someone speaking.



How can I improve my results???
Screen Shot 2019-12-23 at 8.11.33 pm.jpg

@michael667 I’m a little late to the party, but just pitching in here to say that I was able to get a pretty good result, similar to that of the out-of-box demo.

I have the ReSpeaker Mic Array v2.0 connected via USB to a Raspberry Pi 4 running Raspbian 10, and I’m running with the native version of Audacity, which is 2.2.2. All I’ve done is set the recording device to “ReSpeaker 4 Mic Array (UAC 1.0)” and the number of recording channels to 6, which I see you’ve done as well. No problems there.

I noticed that your channel 5 (the very last one) is empty. This may explain why your channel 0 lacks the filtering. Channel 5 should normally contain the audio data of the recording minus the voice/speech, i.e., just the music/background noise, as shown in the demo. Maybe the ReSpeaker guys can say something about this. Hopefully this isn’t a HW issue.

Actually, I may have just solved your issue. Out of curiosity, I tried playing music through the speaker on my phone (which is separate from the mic array), and I got an empty channel 5, the same as you.

I think that in order for this to work as expected, the music must be playing through the 3.5mm jack on the mic array board.

You’ll want to select the mic array as Audacity’s playback device and connect an external speaker to the mic array via the 3.5mm jack.