Respeaker Core v2 & Google Assistant Issues with Installation

I realize I’m dealing with hardware, libraries and instructions from 2018 but the Core v2 is the hardware that best fits my project…

I’m struggling to get the Google Assistant SDK installed and could use some help. I am using the IOT image flashed to the eMMC. The board boots fine, is connected via ethernet and I can SSH to it normally.

First challenge is that I see two different installation guides. The one from the respeaker github: and the one from the wiki:

Please bear with me as I’m not a developer but it seems that the major difference between the two is the github version doesn’t use python virtual environment and the wiki version follows Google’s SDK installation guidance and does use venv?

In any case I’ve tried both methods and have failed at both (using both python 2.7 & python3). My first question is, should I expect compilation to be necessary when installing the SDK? Neither version of the docs mention compilation or the large amount of time that this takes when walking through each step. Yet in my case it is always trying to compile beginning with grpcio. I’ve never actually gotten past that component b/c after hours of compilation (during which the RAM is exhausted and kswapd consumes tons of CPU - there is no swap partition) it always fails and the reason seems to change each time I run it (but not due to progress).

If it’s not supposed to be compiling, then my guess is it’s trying to install newer versions of the SDK which don’t have a pre-built binary for the architecture. If this is true, can anyone share what versions of the SDK components the instructions were written for at the time, so I can attempt to force those specific versions to be installed and potentially avoid the compilation and/or errors?

Finally, if I’m totally off-base with my assumptions above, please correct me. Ultimately I don’t care about being right, I just care about getting my project working and happy to take any advice.