Respeaker Array v2.0 Device Not Recognised

Hi there,



I just received a respeaker array v2.0. The guides say it should be detected as a USB audio device when plugging in, however most of the time the computer does not recognise that a device has been plugged in at all, and when it does it appears as “Unknown USB device (device descriptor failed)”. I have tried 3 different cables, 2 different windows latops, a mac laptop, and a linux desktop PC. The windows ones are the only ones that ever detect anything. I tried to follow the instructions here <URL url="https://forum7.seeedstudio.com/t/set-up-respeaker-mic-array-v2/5939/1 text=“viewtopic.php?f=91&t=8023&sid=36e47f08c … 12ce9cbabd”>https://forum7.seeedstudio.com/t/set-up-respeaker-mic-array-v2/5939/1 but this doesn’t make sense, as it doesn’t appear as a SEEED device. Visual inspection shows what appears like significant rework of the board, and I suspect it is faulty. Please advise the best option for use to get it working/get a working device

Hi there,



For the linux and mac, we do not need any driver. So it maybe hardware issue. Please take a picture about the mic array v2.0 and send it techsupport@seeed.cc . we will process it. thanks.



best rgds

Bill