Respeaker 2 mic wont install on RPI0W

Plain and simple. I’ve tried a few times using the makers guide and the wiki. After leaving it in a loop for over 3 hours, I had to Press CTRL-C and quit. That meant I had to reflash the sdcard, but no bother. So a fresh install from rpi foundation website.
Linux 5.4.51+ #1327 armv6l on a Raspberry Pi Zero Wireless with a 16gb sdcard.

it starts, almost immediately with an error:
“W: --force-yes is deprecated, use one of the options starting with --allow instead.”

Then it says:
“make -j1 KERNELRELEASE=5.4.51+ -C /lib/modules/5.4.51+/build M=/var/lib/dkms/seeed-voicecard/0.3/build…(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.4.51+ (armv6l)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.
can not compile with this kernel, abort
please try compile with the option --compat-kernel”

I can post the make.log but they are all the same type of error, so heres the end one:
" stream_name
/var/lib/dkms/seeed-voicecard/0.3/build/seeed-voicecard.c:616:2: error: implicit declaration of function ‘asoc_simple_card_clean_reference’; did you mean ‘asoc_simple_clean_reference’? [-Werror=implicit-function-declaration]
cc1: some warnings being treated as errors
make[1]: *** [scripts/ /var/lib/dkms/seeed-voicecard/0.3/build/seeed-voicecard.o] Error 1
make: *** [Makefile:1709: /var/lib/dkms/seeed-voicecard/0.3/build] Error 2
make: Leaving directory ‘/usr/src/linux-headers-5.4.51+’"

We found this problem last Friday.The main reason is that Raspberry PI has updated the kernel to 5.4.There are some incompatibilities.We’ll fix it as soon as possible.

Have you found a solution yet?
This product is useless on RPi without it.

You can use it with older versions of the Raspbian (not raspberry pi os).

The new kernel has entirely different names for things and so the script, which requires compiling the kernal again, needs modifying to fit. Well beyond my abilities, but as said above the mods are working on it.

I just bought this card, am trying to install on zeroW too. Using rasbian 05-02-2020 version and not upgrading it after installation. The install fails because the script upgrades the kernel to the lastest one, with which it is incompatible. I had my brother look over the script, as hes an IT guy and I am not, we modified it to not upgrade the kernel. This nearly works, but it fails to install the - capture device. Any ideas/updates on this, its a bit frustrating, you are selling these cards despite the current version not being functional.

It seems someone else has cloned this and solved it

huge thanks to HinTak