Reserver - Ubuntu No Networking

I recently purchased a Reserver (reServer i3 1115G4(16G+512SSD/W)). I have installed Ubuntu 20.04 LTS. But I cannot get it to pass any network traffic on either of the network ports. I’ve tried setting a static IP as well as using DHCP. It gets DHCP IP no problem, but I am unable to ping in/out of the system. I’ve tried pinging to internet i.e. as well as the gateway IP and even another device on my network. I know the network is fine since all other devices are working fine and I’m getting a DHCP IP assignment. I have tried reinstalling Ubuntu incase it was a corrupt install, but that didn’t make any difference. Everything appears fine otherwise, no errors in dmsg, I do get errors on boot related to waiting for network to start and cloud-init not reaching the internet. But no issues with drivers and both NICs as well as wifi card are seen. I should note I have also tried setting up wifi with the same results.

Does anyone know any tricks to get Ubuntu to work on the Reserver?

1 Like

An update to this, incase anyone else runs into this. VLANs were the issue. Makes no sense as anything else connected to the port works fine, I tested with a Pi 400 and Windows PC, as well as when this thing had Windows preloaded. The only way to get it to work is to remove the VLAN assignment and set it to the default vlan. Then it connected and worked fine. There must be buggy drivers for these NICs on Ubuntu. I also had issues with the wifi though, not sure if that was something different since there is no vlans on the wifi.