Rephone LCD on but not working


I managed to reset my rephone to the default program.
However, now the LCD touchscreen is screwed up. it cant sense at all. even though there’s a original program screen display.


Could you please describe it a bit more?
You got the rephone, reflashed it, copied the things needed, and now the phone starts, you can turn it on, but the touchscreen seems defect?
You turn it on by pressing the button or it can turn on by touch?

Have you set up the debugger? You can check it, it sends a debug message if a touch is detected (as far as I know)

Also try reinserting the FPC cable :slight_smile:

There is a Display on the screen when the rephone is turn on, however after awhile the screen will auto turn off.
The touchscreen doesn’t have any touch responds.

If you can run the debugger, check if touch events are captured, else just reflash the rephone. If phones can misflash, something like that happen here too.


Attached is the my video testing on rephone for LCD problem

( LCD Problem

( LCD Testing

It kinda seems working - especially the second video shows me that the touch event IS working.
What version are you using of the firmware? The latest 6.4? … %20VXP/MRE

I am following what the staff are teaching me.
This is the email conversation.

These is the link about Rephone source code, vxp file and firmware bin file, you can reset the Rephone to the default.
source code : … urce_Code/
vxp file :
firmware bin file :

In, the graphic is no any rotate. But in, the graphic is rotate 180 degrees.
So the touch x, y value need to be rotate, you can find this code in file gui_glue.c line 160,
y = 239 - y - 8;
x = 239 - x;

But now it seem the x value is mirrored.
You can try to change the code in file tp_goodix_gt9xx.c line 304, build the code and copy the vxp file to memory.
tpes->points[i].x = 239 - get_one_point.x; - > tpes->points[i].x = get_one_point.x;

This is the results after the change but…
First try
Second try


i am facing the same problem with the LCD display.
Got my rePhone kit and the extension pack, pluged it together played a little with the led-matrix board and the basic-sensor, all works as expected. LCD was responsive and the touch events were handled correctly.

Then i installed eclipse (latest CDT Version Mars.1 from eclipse download page) and the LinkIt plugin, flashed the board with the firmware to program it. The ‘hello world’ example worked, so i tried the ‘Framework_Touch’ example from the LinkIt Assist 2502 SDK Example Wizard, build the application and load it on the board.

Application shows a ‘open application success’ message (like in the second youTube video turned around 180 degrees) but no touch events are recognized. Also the application can only be stopped when i unplug the battery. Pressing the switch on the board has no effect.
From that moment on the LCD behaves like descripted in this thread. I have resetted the board several times an copied firmware and vxp file from github to the board but the result is always the same, LCD is not working :frowning:

Then i installed the arduino IDE flashed the board and tried the ‘Touch’ and ‘LCD-Test’ examples. They work !!!.
Touch events are handled and the output on the display is not turned around.

So i assume that the LCD/Touch Device is not broken and the problem is in the rePhone software using eclipse and the LinkIt SDK.

@chao zhang and wayen weng, any idea whats going on???

kind regards

I think I’m having the same problems as Stefan.

Using the Eclipse SDK, the LCD is working fine for me but Touch doesn’t work.

Using the Arduino SDK everything is working fine. Both Touch and Drawing to the LCD.

Using the Lua SDK, I have the same problems as with the Eclipse SDK - the LCD works fine but not the Touch.

Any ideas? Kind of a big issue this so any help greatly appreciated!



My Final Video and conversation with wayne. They concluded my LCD is hardware issue.
In the video, i can saw when release touch, the lcd display event almost is 6, not 2. It means that hadn’t detected the release motion.
You can watch the video that the normal touch release test, event value always is 2.

     I am so sorry to say there maybe is a bug of hardware.
     Please don't worry, my colleague will contact with you as soon as and to solve the problem of hardware.

The Rephone UI will change after touch release have been detected.

It seems the touch release detection not responsive.
Please flash the code ..\LINKIT_ASSIST_SDK\examples\API\Framework_Touch, make the motion of tap and release, and the event value will change from 1(Tap) to 2(Release).
Is it the event detection is same to the motion changes? And is it change in almost same time?

There is the event define in file "vmtouch.h" line 45.

typedef enum
VM_TOUCH_EVENT_TAP = 1, /* Touch down event. /
Touch release event. /
Touch move event. /
Touch long tap event. Note:
invoked when the Touch is tapped for
a period of time and stays at the
same place where it is tapped down.
2. If Touch move happen after Touch down,
there will be no
happen one time at most before
Touch double click event. /
Touch repeat event. Note:
1. VM_TOUCH_EVENT_REPEAT can happen after
2. The coordinate follows
Touch abort event. */


(Wayne’s LCD TEST) …

Zheng - can you confirm the SDK you’re working with?

Is it the Eclipse SDK or Arduino?

I can’t get ANY touch events working using the Eclipse SDK :frowning:

Tested again with the touch test for arduino.
It seems that my LCD has a hardware problem, i can only see event 3 followed by event 6, not 1 and 2.

The framework_touch example from the LinkIT SK does not work at all, there is no touch event recognized, the registered handler is not executed :frowning:

@Seeed-Support I think the touch controller has a problem, how can i change the broken hardware?

I remember the touch hardware reset pin is change to gpio 19. So when use …\LINKIT_ASSIST_SDK\examples\API\Framework_Touch,
it is need to change the number of touch reset pin, in file tp_goodix_gt9xx.c line 10:
const VMUINT8 gpio_ctp_reset_pin = 0;
const VMUINT8 gpio_ctp_reset_pin = 19;

Brilliant - this fixed my issue. Thanks!