RePhone: how to flash the Firmware for Arduino IDE ?

I assembled my RePhone. Everything (touch screen and so on) is working fine.

Then, like described here … ePhone_Kit
i installed the drivers. Both com ports are listed in the device manager.

Next i tried to update the firmware but failed:

  • My RePhone was off (LED off)
  • Updater strated and download button clicked.
  • USB connected to PC
  • LED becomes green. RePhone starts in mass storage mode (drive shown in the windows explorer).
  • Firmware updater time out message.

What’s wrong? Do i have to erase the files in the mass storage before?

Same problem here. Any solution?

tried to post a screenshot but got a message: “Your post looks too spamy for a new user”, so reassemble this:

imgur / 5jqid38.png

Hi m.duerr:
Maybe the the battery is not well connected, or the battery is without enough power.

I had very similar issues flashing my board. I have now managed to do it.

To get it to work I ended up pulling an old Windows XP SP2 machine out of the cupboard. Wonce I was using that it worked without issue. I have now reflashed my board and have been playing around with some of the example code.


Hi everyone,
I have the same issue on Win7 64bit, and I’ve done the following:

  • installed the drivers
  • COM ports are listed in the device manager.
  • attach the battery to RePhone
  • press the power button to switch off (led not blinking)
  • start the updater
  • attach to PC via USB
  • LED becomes green. RePhone starts in mass storage mode (drive shown in the windows explorer).
  • Firmware updater time out message.

Any solution to make it work with Win7 ?


Is there any solution? It also not works with win10 -> my Rephone is now “empty”…

I doubt we will get support in a timely manner…

From my experience:
Seeed seldom responds even with faulty hardware/RMA requests
Most of China is out on holiday making the idea of doing direct business with Any company in China a problem to most of us in the rest of the world.

My opinion:
Seeed needs to hire and train people for support (not just development)
ANY company that wants to sell retail directly to the rest of the world needs to have someone available for support and fulfillment purposes. It is a fools quest not to do business like this. A few countries/companies tried not to do this and most have hired/subcontracted people to fill in this shortcoming.

After flashing, you should copy an initial folder structure with some files to run. (also running W10) It can be found on the wiki, copy the content of this folder. … 0Kit%20VXP

Also, general answer: my rephone stopped responding several times. Flashing should be done like

  • start the flasher and set up the image
  • pull out battery from rephone and reinsert; plug USB cable in rephone
  • click start flashing in app
  • plug rephone to USB
  • now rephone is flashing, and don’t forget to copy the stuff needed on the disk!
    Worked like a charm for me.

Trouble updating the Firmware. I did not want to hassle with the Signature Driver issue with WIndows 10. Used a Windows 7 disk and was successful with the drivers. However, the firmware never displayed a progress bar. It was stuck. Made sure the battery was charged. Tried multiple changes and attempts, with the same stuck position when it should have displaying the progress. All grey/gray. Hopefully, this will be a quick fix after CNY so we can use a Windows 10 system as is. Or possibly a Linux OS (Raspberry Pi or Ubuntu would be OK as well - providing the instructions are easy to follow for Noobies.


Could we get a full support for Windows 10? I parsed the different posts and saw no solution for the moment.

When I connect my RePhone to my Windows 10 PC it even doesn’t show the two com ports as described here: … the_Driver

When I connect, disconnect and reconnect the RePhone nothing changes on the device list.

Thanks for any help.

Hi m.duerr,

If the Firmware updater is working well, you shouldn’t be able to go into the mass storage mode, instead you can find a COM PORT in Device Manager, which is used for firmware flashing. Please recheck if the driver is well installed, then go through the wiki again.

Thank you.

I have this problem as well - not being able to flash new firmware on RePhone.

I read all the online posts and followed the steps over and over again - but the tool always times out and cannot update the firmware.

Very disappointed in the quality of this product.