"Reorder" button does not work.

I would like to reorder a Fusion PCB job.

I click the “Reorder” button on the list of my previous orders.

A pop-up box allows me to change the Quantity.

I click the “Add to Cart” button.

Nothing appears in my cart.

My cart remains empty.



Hi David,

Thanks for the heads up and sorry for the inconvenience, there was a bug in the latest update but it should be fixed now. Would you mind trying again?


I’ve had what sounds like the exact same problem the last several days. I tried from Chrome, FireFox, and IE and the “reorder” button is not working. The behavior in FireFox is slightly different in that pop up box for the quantity just spins when you click “Add to Cart”. In the other browsers, the pop up goes away but with all three browsers nothing ever gets added to the cart. Chatting with support has not been productive so far.


Hi Craig,

Thanks for the heads-up, we’ll have the IT team look into it and keep you updated. I have a little suspicion as to why it may be happening :geek:

The reorder button still does not work!

I click reorder, then add to cart. The icon on the button just spins.

Nothing added to my cart.



Hi David,

Thank you for the heads up but this problem should have been resolved the last time it was brought up. Could you give us some more information? I just tried it on Chrome and Edge and both are working fine. What browser are you using and what are you trying to reorder? Note that the reorder option is not available for PCBA orders since the price and availability of components are always changing.

Many thanks for your cooperation!

Hi Carmen,

I sent you a PM with screen shots in a PDF doc.


Thank you!