Reliability problems with Xiao?

Hi,
I’m quite new to Arduino world, but have some confidence and I’m trying to make a domotic project for my house using many Arduino IDE compatible devices and nRF24l01.

So when I discovered this Xiao I bought 3 and was very enthusiastic about it, so much so that last week I bought another 3 (am I wrong or has the price gone up a bit?).

After that, within a very short time, 2 of these Xiao stopped working altogether.
The first one when I was trying to do a sketch upload (modifying just a constant, before was working), and the second one when I unplugged the Xiao from the PC to connect it to a USB wall adaptor.
Both have the same behaviour, green light on but totally passive I/O, and connecting them to the PC (Win10 Pro x64) they are not recognized at all and it doesn’t even emit the classic sound of when a device is connected.

I’ve tried looking on this forum, there seems to be a reliability issue, some have managed to restart the controller with a reset, or double reset or changing the pc USB port, but none of these methods worked for me.
I found in the forum also a solution using a raspberry, but unfortunately I don’t have one, I have instead an Arduino Uno and an Arduino Nano, is there any other way to “revive” those Xiao with the elements I have available?

Losing 2 Xiao out of 6 after only one month would be very disappointing for me because it would mean that I can’t even rely on the remaining ones for projects to be permanently installed in the house…

2021/05/31 EDIT: Just now an other one from the last purchase is gone, 3 out of 6 are dead within one month…

Have you tried Reset or Enter Bootloader Mode?
It is introduced in XIAO’s wiki document.
I’ll post it, and you can try to see if it can solve the problem. If it doesn’t work, tell us your problem again.

Enter Bootloader Mode

Sometimes the Seeeduino XIAO port may disappear when user programming process fails. we can solve this problem by the following operation:

  • Connect the Seeeduino XIAO to your computer.
  • Use tweezers or short lines to short the RST pins in the diagram twice.
  • The orange LED lights flicker on and light up.

At this point, the chip enters Bootloader mode and the burn port appears again. Because the samd21 chip has two partitions, one is the Bootloader and the other is the user program. The product will burn a bootloader code in the system memory when it leaves the factory. We can switch modes by performing the above steps.

Reset

If you want to reset the Seeeduino XIAO, perform the following steps:

  • Connect the Seeeduino XIAO to your computer.
  • Use tweezers or short lines to short the RST pins only once
  • The orange LED lights flicker on and light up.

Please note: The behavior of the built-in LED is reversed to the one on an Arduino. On the Seeeduino Xiao, the pin has to be pulled low, whereas on other micro-controllers it has to be pulled high.

Hi, yes i already tried and the XIAO i totally passive, no orange light comes on, only the steady green one.

Sorry for the trouble, please try the following method to recover Xiao

  1. Turn on verbose upload in the Arduino IDE preferences

  2. Plugin Xiao, it won’t show any COM/serial port.

  3. Open up the blink example(Examples->Basics->Blink)

  4. Select the correct board in the Tools menu,seeeduino Xiao. (physically check your board to make sure you have the right one selected)

  5. Compile it(make sure that work)

  6. Click “Upload” to attempt to upload the code

  7. The IDE will print out a bunch of COM ports as it tries to upload. During this time, double-click the reset button, you’ll see the red pulsing LED that tells you its now in bootloading mode

  8. The board will show up as the Bootloader COM/Serial port

  9. The IDE should see the bootloader COM/Serial port and upload properly

Hi, thank you very much for your reply, i tried as per your suggestion but look like Arduino IDE does not search for “a bunch of COM ports”, instead it try to upload to the last port that was available.
This even closing and reopening the IDE.

OK, so what does your windows Device Manager show as com ports?
Could be a driver recognition problem. Have you tried to connect it to another PC or another cable.
It’s clear the board has power but no comms are established.

Hi TestMate.

Yes i tested with an other PC since i’m trying to make a network with Xiao and nRF24l01 so i’m using 2 PC to check the serial communication of 2 device at the same time, and the cables are the same that i have used until now, (and they work with other boards).
The Xiaos just suddenly stop working during an upload, when usually disconnect and reconnect during the board reset, it just didn`t reconnect and was no more recognized by PC.
I also tried in device manager to enable “show hidden devices” and delete all COM ports, but it still does nothing when i connect the Xiao.

All three devices has this behaviour, steady green light on and nothing else.
I have read on this forum that someone has unbrick the Xiao with ST-LINK and OpenOCD, but having the same issue on 3 devices of 6 i suspect that all those boards has some heavy defect and i don`t want purchase accessories for something that i will never use any more.

Of course i will be very happy if i’m wrong.

So after 8 days from my last post there is no answer,this means that there is no solution or alternative to avoid this situation?
Just an update, i forgot that i had ordered an other Xiao from e-bay, and meanwhile an other one has bricked, so 4 out 7 are no more usable.

I think that i will stop to use this board until there is a solution…

I met this problem mate.
You just go to this link: https://github.com/Seeed-Studio/ArduinoCore-samd/tree/master/bootloaders/XIAOM0
download the XIAO bin file then, Use SWD to burn the firmware into XIAO, it will be work again.
How to unbrick a dead xiao using raspberry pi [ GUIDE ][openocd]

Also, you can buy a Jlink to burn the firmware into XIAO.

Thank you very much for your reply 0hotpotman0!

I’m not an advanced user so i would like to undertand 2 things:

  • The booloader in the link is the official one from Seeedstudio?
  • This bootloader will fix this problem?

Because I don’t want purchase other accessories to have the same problem after some days.
So if the answer is yes to both, do you have a step by step guide with cheaper programmer? i don’t have a raspberry and i don’t want purchase it just to fix a Xiao’s problem.

Thank you.

I saw this solution on the XIAO official via using the raspberry pi.
but I did not use it, coz I know this way is the same with use SWD to burn the firmware into XIAO.

So I really recommend you use the XIAO expansion board to connect with the XIAO, but you need to get a J-link device and download the J-link software. I have used this method to solve the problem, absolutely work.

Like this Jlink device I’m using, and I mark the arrow that means you need to connect to SWD on the XIAO expansion board.
image

image

Put the bin file on the J-link software then burn into XIAO, done.

Thank you very much for your reply, i appreciate it very much.

I will try this method with J-Link, but for the Expansion board, I dont know, I dont think I`ll buy any more products from Seeedstudio.

Anyway, thank you very much again for your help!

idk, I did some projects via using Seeedstudio products like grove modules, and other Arduino boards such as Wio terminal, Seeeduino Lotus, there is no problem for me, it depends on your PC everoment, cable or wrong operation that could make some accident. anyway, if you still keep using XIAO, just try the XIAO expansion board, it really convenient.

good luck amigo