Reflash Xadow Duino

Hi -

is there a way to reflash the firmware for the Xadow Duino?

Right now, I can’t get get anything to finish uploading. It stays on “uploading …” and the actual code on the board doesn’t change. So I was hoping to reflash it, but I can’t find instructions / files to do that.

It’s just plain Arduino. Try reflash bootloader, hopefully it goes with the usb, if not, another Arduino can act As a programmer, and you can reflash via isp port.

I wasn’t able to just do that because the boards.text doesn’t have the Xadow.bootloader.tool=arduino:avrdude line. I have added that.

What is the correct programmer to use for the Xadow Duino?

I tried with AVR ISP but it never finished burning the bootloader - I just get “Burning bootloader to I/O board (this make take a minute) …” forever.

If you are using avrisp, just choose the atmega32 profile (if it’s the microcontroller) and reflash it As an atmega.

I haven’t reflashed anything, so none of this was something I could “just” do. If others haven’t ever reflashed anything and need to do this, start at: … bootloader

I’m using arduino-as-ISP.

Here’s what I ended up doing that worked, if anyone else is trying to reflash the Xadow Duino and doesn’t know how to reflash boards in general yet:

-Edited boards.txt in [arduino path]\hardware\seeeduino\avr to add “Xadow.bootloader.tool=arduino:avrdude” in with the other Xadow info (for me it’s added as line 99), and change the line with “Xadow.bootloader.file=Seeeduino-Caterina.hex” to “Xadow.bootloader.file=Seeeduino-Xadow.hex”
-Copy the folder “bootloader” in from Seeed32U4Bootloader-master\Seeed32U4Bootloader-master\Seeeduino Xadow\ to [arduino path]\hardware\seeeduino\avr
-set up pins on the xadow for the ICSP pins
-Connected the ISCP pins to an Arudino Uno as indicated at … bootloader
-Uploaded the ArduinoISP example sketch to the Ardunio Uno
-Left the Arduino Uno port selected, changed the board to Seeduino Xadow
-Tools > Burn Bootloader

Hopefully this will save someone some “avrdude: can’t open input file hardware\seeeduino\avr/bootloaders/Caterina-Xadow.hex: No such file or directory” errors!