RE: Flashing Firmware for the MotorBridgeCape


I listened to the instructions on the Flashing the Firmware for the MotorBridgeCape. I came up with this error.

./script/flasher MotorBridgeFirmware.bin
make: execvp: ./script/flasher: Permission denied
Makefile:202: recipe for target ‘flash_firmware’ failed
make: *** [flash_firmware] Error 127

Please advise. I need assistance. When anyone has time, please try to explain what I did wrong. I tried to go to the flasher file and see the tty02 section of the software. It is already listed as tty02. I had to make no changes.


P.S. Thank you. I had to use WinSCP to change file names for my BBG because the .zip file unzipped as Motor Bridge Cape v1.0 and not Motor_Bridge_Cape_v1.0.
Third Issue.JPG
Second Issue.JPG

Hello Again,

Seth here. I have been up and down the file tree to trying to update the firmware. I have been unsuccessful so far. Does anyone know how to make the MotorBridgeCape work?


P.S. I am still trying to update firmware to make my MotorBridgeCape work.


Here are some screen captures.


Hi Seth.

Did you end up making this work? I did manage to update the firmware, but it only worked on the Linux image/kernel that came installed on the eMMC of the BBG. A newer image did not work. I did not investigate this very much.

The “permission denied” error … do those files have executable permissions? It’s possible that that did a “chmod +x -R” on the entire directory before I ran it.



I have taken a break for a bit. I am back with it now. I have a project that I am trying to complete. I used to get some feedback from a couple of people from

I have been unable to get the updated firmware but I see that the update is from 2014. Like you said, the systems have been updated. I can use chmod to make files executable if necessary.

I will keep trying.