Raspi Firmware Bump to 6.1

Hi all,

I am currently facing an issue:
I flashed a Raspberry Pi 3A+ incl. ReSpeaker hat with the current Pi OS 64bit light (still kernel 5.15).
There has been a kernel bump in (I think) the firmware package. So somewhen in the installation process via install_arm64.sh I encounter the below error which is not fixed when rebooting and re-executing the installation.

Has anyone experience with this situation? Should I just wait for newer Pi OS releases?

Thanks and regards,

OK, update:

Obviously, the new kernel 6.1 is rolled out via APT. So dist-upgrading already solves the kernel mismatch.
Nevertheless, the installation script is not able to properly retrieve the installed kernel version on the system and still throws the above error, although the kernel versions are actually matching…

Did you solve it? I also encountered the same problem.

Hey guys,
The problem still exists. I’m not able to use the driver on my new RPI system.

Any workarounds here?

May I ask which specific product you are using?

Hi and thanks for your response!
We, for instance, use the 2-mic PiHat like this one:
ReSpeaker 2 Mics PiHat

A usual host would be a Raspberry Pi 3 (A or B)

Perhaps you can try rebrushing your system to 64-bit and changing the clone link for the new seeed-voicecard according to the following post
I hope this is helpful to you.

Hi @Seeed_Seraphina,

thanks a bunch for that suggestion!
Unfortunately, I end up at a similar problem (see below).
What about the others? Do you experience something similar?


From my side, I’m still using the 6+1 mic array.

In fact, I tried to modify the install script to make him believe that the right headers are installed, as in my understanding, when he extracts the information about the current kernel, he doesn’t take into account the “-v7+” info, but afterwards, during compilation, there is an error.

Best regards,

I’m facing the exact same thing on fresh install of Raspbian Bullseye 32-bit on RPi Zero W (v1.1) and Bullseye 64-bit on RPi4, with the same 2-mic Pi Hat.

So…I heard back from Seeed tech support the email I got. They actually said to use this repo. I asked them why they hadn’t bothered to update the wiki with a note or something. Just sent it a few minutes ago, so haven’t heard back yet.

I gave that a try, and works now.

@JAAdrian @Joseph80909 @macload1 tagging you in case you didn’t get a notification from my previous post.

EDIT: And I just got this back from their email support. Are you FREAKING KIDDING ME.

We have discontinued software support for the respeaker product line because some customers have integrated respeaker into their devices and we still sell it as a hardware device.



I suppose that the automatic translator missed something there…
I understand that in that way, that they wanted to scratch the whole respeaker line but they continue to sell the hardware for the customers that integrated them into their products.

Too bad, I like the product…

Best regards,

I have also encountered this problem. Can someone explain it carefully?

It means that seeed studio has abandoned the reSpeaker products, but keep making them because there are some companies that have integrated them into products, so seeed is still manufacturing the hardware, even though they’ve abandoned the software.

Although it appears that someone very helpfully via https://github.com/HinTak/seeed-voicecard repository is maintaining, at least a little bit, the installation source code for newer Raspbian versions.

However seeed apparently can’t be bothered to tell people this on the store page or their wiki docs.

Hm yeah, that’s somewhat unfortunate :frowning:
I was playing with the driver version of HinTak but always have issues regarding the compilation of DKMS modules. Unfortunately, he/she did not activate issues so there is probably no way to find out the issues on my side.

May I contact one of you guys, who was successful with the HinTak routine?