Rainbowduino v3.0b getting started challenges

Hello All,

Just received a Rainbowduino and am attempting to program it but get consistent failures. Environment works fine with also-just-purchased Duemilanove. Rainbowduino, however, doesn’t respond. Tried both Win7 and Ubuntu 12.04 using Arduino 1.0.5 environment. Enabled verbose output and get this on my Linux system:

Experimental: JNI_OnLoad called.
Stable Library

Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7
Binary sketch size: 1,084 bytes (of a 30,720 byte maximum)
/home/jheath/Downloads/arduino-1.0.5/hardware/tools/avrdude -C/home/jheath/Downloads/arduino-1.0.5/hardware/tools/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/ttyUSB0 -b57600 -D -Uflash:w:/tmp/build412561158710153776.tmp/Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep 9 2011 at 16:00:41
Copyright © 2000-2005 Brian Dean,
Copyright © 2007-2009 Joerg Wunsch

     System wide configuration file is "/home/jheath/Downloads/arduino-1.0.5/hardware/tools/avrdude.conf"
     User configuration file is "/home/jheath/.avrduderc"
     User configuration file does not exist or is not a regular file, skipping

     Using Port                    : /dev/ttyUSB0
     Using Programmer              : arduino
     Overriding Baud Rate          : 57600

avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done. Thank you.

Bad board or bad settings or something else?

I’ve tried different versions of the FTDI drivers under Windows. Duemilanove continues to work just fine. Rainbowduino fails regardless. Been writing code for decades, mostly embedded for telecom and datacom. New to Arduino. Any guidance will be greatly appreciated.

Best, Joe

Appears to be a bad board. Received a second unit, plugged it in and loaded drawChar and PlasmaMatrix example apps without any issues.

Planning to return the first unit unless there is some recovery methodology recommended.

It is discovered when plugged in and both TX/RX LEDs shine during the enumeration process. I never see the TX LED illuminate during the load process on the failing unit.