Rainbowduino v3.0 and original firmware in it


I search for the original factory firmware that is in my Rainbowduino v3.0b 25/08/2011
Because now nothing happen when I upload a sketch into my Rainbowduino and I don’t know why? So I planned to reset it on factory default to test if it works…
Someone could help me to solve the problem?

I use usb cable to connect my Rainbowduinov3.0 onto my computer. Then I placed rainbowduino library into the library directory of ArduinoIDE 0.23. Then I upload, for exemple, Plasmamatrix1.pde but nothing appens after.

I don’t know what to do?


First,make sure you choose the right Tools for Serial port(the COM) and Board(ATmega328) to connect with your Rainbowduino.

After upload the code, no error display.

If still nothing happen, tell us more detail.

Best regards


Hi Yuriq,
Thanks for the answer, I solved it by myself yesterday.

I think I was selected the wrong board. I used Arduino Pro Pro Mini 3.3V/8MHz ATMEGA 328 instead of Arduino Pro Pro Mini 5V/16MHz ATMEGA 328
I haven’t got an error and I don’t know why, it transfered the code to the Rainbowduino but then nothing appened on the matrix

Now with Arduino Pro Pro Mini 5V/16MHz Atmega328 it works!!

So pay attention, if you have a Rainbowduino v3.0 board, check that you select Arduino Pro Pro Mini 5V/16MHz Atmega328 (in the menu TOOLS\BOARD…)

Oh, I see.

The difference between them is not only a memory. Your boards are different crystal frequency between each other, it would change communication baud rate that you should wright the correct baud rate in the code to upload.

But glad to know you can solved your problem.

Best Regards


Thank you john_lenfr!

I have been looking everywhere to find out why i couldn’t communicate with my Rainbowduino v3.0.

Maybe i missed something major, but i couldn’t see this in the Wiki. It would save a lot of hair pulling if it was!

Actually Seeeduino v3.0 is used by Dumilanove bootloader.
So best way is choose Dumilanove.