Rainbowduino v2 problems


I am trying to upload the Rainbow 2.71 firmware to my Rainbowduino v2.0 as per this guide:

seeedstudio.com/wiki/Rainbow … inbowduino

I am using a UartSBee to the USB bus to connect the Rainbowduino to my PC and the UartSBee device shows up on COM6

However I get this error when I try and upload the firmware:

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.
Arduino: 1.0.6 + Td: 1.24 (Windows 7), Board: “Arduino Duemilanove w/ ATmega328”
avrdude: usbdev_open(): did not find any USB device “usb”

I have tried switching the programmers around and no luck. I have also installed Atmel AVR Studio but I don’t have a clue how to use it to upload new firmware!

Can anyone help at all?

Many thanks,



This issue is probabily due to driver incompatiblity of programmer after installing Atmel AVR studio. Try to roll back driver to Arduino version of driver. Otherwise, uninstall all FT232 drivers completely.Reinstall Arduino IDE (& driver).


Thanks for your suggestions.

I rolled back the driver and reinstalled the arduino IDE but i’m still getting the same error.

It was also happening before i installed AVR studio in the first place.