rainbowduino V2 not working

im still attempting to get my rainbowduino v2 to work with no success.

what i have tried so far:
tried uploading through Arduino UNO, result failed.
tried through a arduino mega, result failed.
bought and tried a UartSB, this also failed.

ive got a constant powersupply going to the rainbowduino of 6V and it just displays the default pattern, not sure what to do now.

anyone have a solution for this?

Do you try it as the Wiki said?
seeedstudio.com/wiki/Rainbow … Atmega_328

yes, after reviewing that, i wondered if not connecting the SDA and SDL connections did something, and sure enough i had to have the SDA and SDL connections connected on the arduino and rainbowduino, i now need to find firmware that works as all other firmwares i have tried do not compile and give me lots of errors.

First,i think you should upload the firmware(you can download from here:http://code.google.com/p/neorainbowduino/downloads/detail?name=neorainbow-0.82.zip&can=2&q=) to the rainbowduino,as the wiki said,use the arduino to connect the rainbowduino like this,
(Note:the arduino should be upload the sketch like this:

void setup() {} void loop() {} )
For more detail,please visit:http://code.google.com/p/neorainbowduino/
Or you can post me the compile error picture,so I can see what’s happen.