RainbowDuino Firmware Load Method

Can someone point me in the correct direction? I have a Rainbowduino V3.0b. It has a USB port. I also have an Arduino V3. What software do I need to load the Rainbowduino? What jumpers can be set on the Rainbowduino alone to get this done with this software? Can the Arduino be used as a front end from the USB in order to get this done?

Dear customer,

You can view at our WIKI.seeedstudio.com/wiki/Rainbow_Cube
There are some demo code and a libraries for Cube.
Rainbowduino actually already has a MCU in it so you can use Arduino IDE program it directly without jumper wire.
You also can use Arduino V3 via RX,TX to control Rainbowduino.
About schematic also attach on WIKI. Use Eagle you can view it.

Hope can help you.
Best regards,


Folks, thanks for the tip to the right wiki page to find the right download! But… Now I am having trouble with the “step 1”…

core.a(main.cpp.o): In function main': C:\Users\K. G. Deitz\Documents\Rainbowduino\arduino-0022\hardware\arduino\cores\arduino/main.cpp:7: undefined reference to setup’
C:\Users\K. G. Deitz\Documents\Rainbowduino\arduino-0022\hardware\arduino\cores\arduino/main.cpp:10: undefined reference to `loop’

This wouldn’t be so bad if I could see the code and perhaps do something with it! But the code screen is blank unlike all the other example projects/sketches!

Please advise.

Well… I think I found the correct .PDE file and loaded it… I can see there is serial communication going on between the Java control panel and the target Rainbowduino. But, no LEDs on the 8x8 array are lighting! I’ve already tried reversing it.

Viewing the schematic… There is supposed to be a green LED that lights when power is on. It never lights. Perhaps it is backwards or something is bad about the artwork or the current limiting resistor. Also, how is it possible that a whole array of LEDs can be bad?
When I first got this thing, the initial firmware that was on it lighted a single red LED off center of the array. Now that I have the correct code? The RX LED indicates communication with the MTX software, when “playing” a sequence of frames. It seems to me that if the LED array got plugged backwards it shouldn’t damage anything, it would just reverse bias diodes and there would be
no forward current flow. Any current flow would be limited by the constant current LED driver. The micro will take the firmware, proved that using the BLINK example on pin 1 and altering delay times… The micro syncs up and takes the MTX firmware as well. So, power must be on. Any thoughts? I think it is time for me to pull out the oscilloscope and look at the LED array pins…

Dear customer,

If you attach your photo here it could be helpful.

Best regards,


Yuri, what specifically would you like a photo of?

  1. The diffused “square pixel” 8x8 array?

  2. The Green,“power-on” LED on the Rainbowduino that does not light?

  3. The position of the switch?

  4. The RX/TX LEDs switching on and off as the MTX Java application sends data while the 8x8 array displays nothing?

  5. The scope pictures (not yet taken) of the signals provided or not provided to the 8x8 array of unknown functionality?

Tomorrow, I must determine via scope on the pins providing VCC to the array, if VCC is present. Then while the MTX
Java app is “playing” WHITE-BLACK-WHITE on all of the 8x8 panel, I can look at the voltage of the cathodes of the 8x8
array to see if the Constant Current drivers are switching on/off.

So, I will have more information tomorrow about whether I have a defective 8x8 RGB led array or a defective set of
constant current drivers at the LED cathodes. All of them? How is it possible to blow out the drivers? How would it
be possible to blow out the entire array? A mis-rotated LED array in this case should yield zero current to the CC
drivers, so it should not be deleterious to either LED(s) or drivers. My particular 8x8 array has absolutely no markings.
There are only two ways to position it.

Again, we will know more tomorrow.

Thank you.

Try loading one of the example sketches that runs on its own without being driven by a PC connection, to rule out that as a source of error.

I have tried many other sketches. The only LED activity I can get out of it is on PORT 1 which is one of the LEDs near the reset button on the Rainbowduino board. The LED matrix seems to be dead no matter how it is inserted. 0 degrees or 180 degrees. My matrix has no
polarity marks. Again, when it came, simply powering the board with the matrix attached caused one of the red of RGB leds just off center to blink. This was the behavior of the default firmware with that 8x8 matrix attached. Since then, nothing! I haven’t had the chance to check it with a scope. Unfortunately, here in there are tax clerical duties that need to be observed at this time of year.
Perhaps this evening…

Dear customer,

I still confuse about why you can’t light up Matrix.

I have some question:

1.Did you upload codes successful with Arduino IDE to Rainbowduino?Because I see you attach you error here,and if not, the LED Matrix should not be work, as what did you described about the Led light up strange.

2.I saw your error,so please choose the correct board for Rainbowduino in Arduino IDE “Tool”, Select a Arduino Duemilanove w/AT mega328.

3.LED Matrix is a simple device, so you can use a wire to connect each pin for check it is LED working or not. Please supply in 3V.

Expect you answer.
Good Luck


Well, I didn’t get the chance to put the scope on the pins between the Rainbowduino and the 8x8 array. But the point may be moot. A second 8x8 array came in the mail. This one has a pin 1 indication. I plugged it in, loaded the MTX firmware and then the MTX java app… Nothing. Quite likely more than just the green power on LED is dead on my Rainbowduino. Very disappointing quality. :cry:

Yuri, 3v without a current limiting resistor… Not a good idea for the LEDs. They are low power LEDs with junction voltage depending on color of 1.8 to 2.5. Without some sort of current limiting resistor, it is possible to do damage to the array. Yes, we uploaded mtxfirmware.pde after compilation. Yes, you can see successful communication on the red leds. Again, this particular Rainbowduino never had its green power LED light. Probably misrotated in assembly. Perhaps the Constant Current LED drivers were also mis-rotated? So, I know my 8x8 matrix is okay, I have two. It would be near impossible to not have either one good. I think my Rainbowduino is suspect.

On Sunday, I can try an Arduino Uno V3 with the same arrays and an interposing color shield. Will this work with the same firmware and MTX Java app? This will confirm that I have a dead Rainbowduino.

Dear customer,

About MTX, I’m sorry for didn’t notice on that software.

I need to tell you that the MTX can’t use with Rainbowduino 3.0 version.
It’s just for Rainbowduino 2.0.
Version 3.0 you should upload your code with Arduino IDE via USB directly.

And for 3.0 libraries are all in the WIKI.

Hope can solve your problem.

Best regards,


Dear customer,

Sorry that the MTX only can control Rainbowduino 2.0 so about 3.0 you should upload code directly via Arduino IDE.

You also can use 3v to check Matrix LED, try to light up each by each make sure it is work.

Best regards,


Dear customer,

MTX can’t use with Rainbowduino 3.0. Because it is old version for 2.0.
So for now you just upload code via Arduino IDE to Rainbowduino 3.0 is OK.
Hope can solve your problem.

Best regards,