Rainbow Cube Weirdness

First: I have no idea what I’m doing.

That being said, here’s what I’m TRYING to do: upload some of the sample files in the Rainbowduino to my Rainbow Cube.

I’ve successfully done the following:

Installed the RainbowDuino 3.0 Library into Arduino 1.0.5.
Double-checked drivers - it’s detected on COM11 as a “USB Serial Port” using these drivers:


I’ve double-checked that my Board is set to Duemilanove w/ATMega328
I’ve also tried the 168 setting, with the same result.

When uploading, no matter what, I get:

avrdude: stk500_getsync(): not in sync: resp=0x00

But, the cube seems to respond in that it will halt in its current sequence, freeze 3-4 dots in a horizonal line on the edge of the current color it was displaying, then resetting to the beginning of its sequence. This happens almost every time I try to upload, so it looks like SOMETHING is getting through.

I’ve also tried seeing if uploading in Verbose mode helps. It does not, I still only get the getsync error.

I’ve uploaded every file from Cube1 to PlasmaCube, nothing works.

If I hit upload in rapid succession, I’ll get errors regarding COM11 being in use.

I’ve also hit the reset button and tried again, with no luck.

I’ve tried running as Admin.

I’m on WinXP.

I’m hoping it’s some sort of really dumb, obvious step I’m missing or I messed up the drivers somehow.

I tried referencing (youtu.be/v44i73zmwA4) but there’s like, zero detail in there.

Any help?

Hey there,

Apologize for the issue caused.

We got some feedback that F232RL can’t work in Windows operating system recently and we did a serial test on different PCs and different operating systems.

We are analyzing the issue and need some time to get the root cause. However, if you see the exact same behavior, you can follow the attached instruction to fix it quickly.

If you are not satisfied with this solution, kindly let me know and I will send you a replacement.

Apologize again for the inconvenience caused again.

Best Regards
FT232RL issue.pdf (427 KB)