Programming Arduino with Odyssey X86i51135G7

Hello everyone,
I’m trying to use Arduino on the Odyssey X86i51135G7 board. I followed the instructions given [here] (Getting Started with ODYSSEY - X86J41x5 | Seeed Studio Wiki).
But during the upload, I got the error ‘No device found on ttyACM0’.
After searching the web, I think the error may be due to the versions I’m using (Ubuntu, Arduino and the Seeed package). Does anyone know of a combination of versions that actually works on this board?
→ Ubuntu (18.04) ?
→ Arduino IDE (1.8.19 ) ?
→ Seeeduino Arduino package (1.8.3) ?
I’ve tried other combinations (Ubuntu 20.04, Seeed 1.7.9, Arduino 2.2.0 I think) without success.
Thanks in advance

Hi,Are you using a virtual machine or a Linux host? The instructions in the Wiki link you give are operating under a Linux host, not a virtual machine.In addition, whether you have selected the corresponding development board and port number before the arduinoIDE burning
btw,This may also help to you: Arduino IDE 无法识别 ODYSSEY 上的板载微控制器 - X86J4105/ X86J4125 |看工作室维基 (

Hi, Thanks for the answer. I’m using a Linux host (I installed Ubuntu Dekstop 18.04, alongside with 20.04 and 22.04 to test them all). Yes I selected Seeeduino Zero and port ttyACM0 before uploading. Thanks for the link but I can not find the location of these RST and GND pins: where are they located in the Odyssey X86i51135G7 ? The picture shows it for the X86J4105/ X86J4125, which have not the same layout as the X86i51135G7 that I’m using…

Hi,The x86i3/i5 has the same pin arrangement as the x86j

Hi there, Thanks for sharing the image. I put a jumper between PIN 5 and 7 (GND and RESET) before, and during the upload, I tried several times but I still got the same error everytime.

I tried to use the same versions of the tools as the ones in the tutorial (Ubuntu 18.04, Arduino 1.8.10) but when I try to install Seeed package 1.7.2 I got an error from Arduino board manager. The same for other versions untill 1.7.8. Thus for now I try with 1.7.9. Is this package version (Seeed 1.7.2) not available anymore on seeed website for download ?
If not, what could be a combination that should work ?
I wanted to test with a combination of versions that I’m sure is working.
Thanks in advance

Can you compile it but can’t upload the sketch?The error ‘No device found on ttyACM0’ indicates that the error is at the driver or hardware level, not related to the software, so it is not necessary to consider the ubuntu version or arduinoIDE version.

1.Have you ever tried to connect the same USB cable to the computer with different devices(maybe USB promble)?
2.Have you tried to replace a host to try?
3. The solutions in this post should help you, as this is one of the problems that most people face
[已解决]“在 ttyACM0 上找不到设备”:每次在 Ubuntu 20.04 LTS 中上传到 Nano 33 BLE Sense 失败 - 使用 Arduino / IDE 1.x - Arduino 论坛

Thank you. Yes the compiling is fine and ok for the hardware/driver level.

  1. This is not applicable as the arduino is embedded on the Odyssey board (impossible to change any USB link)
  2. Yes, I got the same error. I tried several combinations: port, board, debug or not, USB stack, … always the same error.
  3. Thanks for the link but going with sudo does not solve anything either …

I agree this should be at the ttyACM0 level (acces right, busy port or something like that, but I dont understand what and how to solve this). I’ve also thought about a baud rate problem, I’ve trie changing it with stty -F /dev/ttyACM0 1200 but this doesn’t change anything. I tried with an other version of bossac, same problem.

I end up having several arduino IDE installed, and several bootable Ubuntu installed on my SD drive. Maybe one of these is keeping this port ttyACM0 busy and preventing me from using it?

Don’t really known what’s left to try :slight_smile: