Problems with xiao esp32s3 connection to port

Hi, I need your help to try to understand if my ESP32S3 Xiao is fried or not. I’m a first user of the board, so I’m afraid I could have made a terrible error.
I’ve connected a 3.7v lipo battery to the Xiao and it started charging (good for now), the battery got recharged, and I’ve tried to use a ble connection with the board but didn’t manage to get it done, ok, so I decided to switch to another board with blue.
I put the Xiao in deep sleep mode (so that it wouldn’t discharge the battery completely) and started to work on the other board, after a while I decided to use the battery connected to the Xiao on this board that I was using, so I de-soldered it from the Xiao and put on the other. The problem now is that the Xiao is not working at all. The port doesn’t appear, when I connect it it simply becomes burning hot, while the LED on board (the one of the charge) doesn’t flicker but stays open. Tried to boot, but nothing, tried all other combinations possible, nothing.
The USBC that I use is the same and has always worked as a data transmitter, tried to change it but nothing.
I’ve also tried to reconnect the battery and the LED started flickering on and off, seemingly like when you connect it to the computer (the battery by the way works fine)
So, now I would really like to understand if this state is temporary and could be adjusted or it’s definitive and I’m a moron.

Thank you all

Have you tested whether the development board works? The reason for “getting very hot” only occurs if the board is burned

Hi, sorry to respond to you now, the fact is that it doesn’t show up in any COM, do you think it could confirm that is burn?

Hello, after reading your description, do you mean plug it in computer with the bootloader mode but no COM port occur? if well, your board may burned, if not you can use the offical tutorial to flash the factory bin to recovery your board: Downloading Guide - ESP32 - — ESP-AT User Guide latest documentation