Problems with Wio Terminal connecting to Blynk and RTL8720 firmware

I’m having some issues connecting the Wio Terminal to Blynk using WiFi and Bluetooth. My first question is - has the firmware been fixed so that both WiFi and Bluetooth work with the same firmware?

I was running the Blynk WiFi temperature example and it was working correctly. I tried running the BLE iBeacon test and it didn’t work. I then updated the firmware to v2.0.1 (erased and flashed successfully) and now the iBeacon test is working. However, now the Blynk WiFi test no longer works (does not connect). I tried running the WiFi scan example and that appears to be working.

I tried to run the Blynk BLE program to control the NeoPixels and that won’t compile. It can’t locate the Seeed_erpcUnified.h file. I’ve installed all of the required libraries per the WiKi.

Ralph @ralphjy I hope this video tutoria could help you .

Any idea where the Seeed_erpcUnified.h file is located? I can’t compile the BLE examples for this project

I was able to run the the WiFi and BLE scan example that was at the link you posted.

I had to change the Blynk WiFi example to change the include file from AtWiFi.h to rpcWiFi.h and now it works. The example at the Hackster link is also incorrect.

Hi @ralphjy

We have updated the library for rpcBLE, please remove the #include Seeed_erpcUnified , you may also check here for more reference:

Hi Anson,

It now compiles but for some reason it won’t stay connected. I tried getting a new token and I’ve also tried the Bluetooth device in addition to BLE.



Sorry, it looks like an issue running on my Android tablet. I’m running Android 8.1 and Blynk 2.27.19. Must just be an issue with BLE/Bluetooth because the WiFi examples are working.

I just tried it on my iPad and it’s working.

1 Like