Problems with using the ArduinoUno with the Rainbowduino

hey guys, i´m a beginner searching for some answers to my stupid questions XD
Please be appreciative, as i sad i´m new at all this, but I need to do this for school…and sorry for my bad englisch^^

I´d like to use my rainbowduino with my ArduinoUno…and maybe with the mtXcontrol…
I tried to follow the instructions on this page: … E.markdown
So I
-installed arduino
-Choosed the right Board (Arduino Uno) and the right SerialPort (COM5)
-Uploaded blank sketch
-connected the 5Wires as shown on the picture … rogram-it/

But than:
I loaded the firmware.pde sketch on the Arduino IDE and tried to upload it, but than he shows me the massage: Rainbowduinodoes not name a type while marking the line:
Rainbowduino rainbow = Rainbowduino(); //max 10 Frames

I guess it´s because I didn´t chenged the processor type to 168, because my ArduinoUno has an 328…
Or did i do smt. different totally wrong? :stuck_out_tongue:
-If it´s the processor type problem…how do I change the processor type?

You may refer here:

You can refer here for how to change the processor type.


I have tried almost everything…and now it works with another Board.
I was able to make it “white” (mix of red/blue)…(step 6: … E.markdown)
But when I follow the instructions, which means closing the Arduino IDE and loading the latest processing IDE as well as the mtXControl application, nothing happens…the mtXControl application cant´t find any output device.
What did I do wrong?


Try this:

WOW :astonished: , nice!!! Now it works…thanks a lot :smiley: :smiley: :smiley:

Cool~ :slight_smile: