Problems configuring Micro SD card

Hi I’m new to this forum and to handheld scopes,and have working knowledge of MS XP but not an expert.
I have a new Nano 3,and bought a micro 2GB Sandisk with it.It shows as 3.67 GB on Properties and not formatted,XP wouldn’t format in FAT 16,so I formatted in FAT 32,
Properties now show the drive as 1.9gb used 1.9gb free.
It does not seem possible that MS would only format 50% of the SD card,equally Sandisk wouldn’t mix up packaging.
Tried a formatter app, suggested on this site which said unable to format or words like it,I’m very confused but that is easy to do.
Any help,bear in mind I’m old and no Guru! Baz

I tried another later model computer,it recognized the SD card ,said was not formatted!
I formatted in what it said “FAT” only ,not FAT 32,I assume it must be FAT 16 then.May be something to do with USB 3 altho I wouldn’t know how to find out.It then showed the drive E on the screen.And at 2GB! Work that one out Mr Gates.
So now I will have to learn how to transfer this complete HDD contents to the other one.