Problem with Grove Camera vision module tutorial

Hi,
I was trying to follow the tutorial on grove Vision module to train and build the ML model. I have encountered an issue regarding the correctly identifying the device as a drive. I could not see a new drive pop-up while pressing the boot button on the module twice, as suggested in the tutorial.

Hence, I also tried few more things, like keep pressing the boot button while plugging in the device. But this also did not help. Could anyone suggest some workarround to this issue or have faced same issue before me. FYI, I am using Linux Mint for my development.

Have you tried testing with other Type-C cables, I get similar problems all because they don’t use the right cable. A cable without a data transfer function may not be recognised.

I have tried that but did not work

My colleague said that this may be caused by you using VisionAI for a long time, you can try to let VisionAI cool down for a while first and then retry.

There is no such problem of overheating as far as this problem is concerned. Because, I have tried after a few hours. Also, I am sitting inside an air conditioner room with temperature around 25 degree C

I didn’t mean it to be overheated and I apologise for my ambiguous expression. What I meant was that if the module had been connected to a computer or master before the bootloader mode was turned on, there is a certain probability that it will not be recognised by the computer. In that case, you need to unplug the module, let it sit for 3-5 minutes and then retry it again and maybe it will be recognized.

I have some clues about what is happening here.
I can sometimes see the device inside a Windows OS. I have tried that in one of the old laptops. But I am using Linux as my main development OS. Here I have seen the device once through Disk management window and the folder was something like /media/user/Grove.
But After that I can not see the device.!!
Do you have any information on troubleshooting the problem, I am unfortunately not a Linux os expert.

well, I see the exact same behavior, and being on linux as well.

I have two vision AI modules, and have tried a few different USB-C cables.

Both my main linux desktop and a raspberry pi does not get the promised USB drive after a double click on the boot button.

Connecting it to my macbook on the other hand, double click on the boot give me the GROVEAI drive withing a second.

wonder if the modules can be upgraded somehow??

Sorry, as I have been busy lately I forgot to sync up the latest developments on this issue. We are currently checking that there will be some MacOS and Linux systems that will not recognise the Vision storage device. Initially, we believe this is a software issue. This has been reported to the R&D department in the last week and they are working on a schedule to resolve the issue, please wait. Again, we apologise for any inconvenience caused to you.