Problem with GPRS shield

After having problem with the “NewSoftSerial” lib i now have faced a new problem. I can’t connect to the module.
i try with the terminal and with code and can’t get it work.

For the terminal i have exactly the same configuration with this pic … ndsms1.jpg
But when i send AT+CMGF=1 i get nothing back. It worked the first time and after it stoped.

And when i try this code Sending_SMS:_using_Hardware_UART-> … dware_UART
nothing happends also.

Any tips what i sould start looking for first?

  1. Last words“Remember to send a Ctrl+Z when your cursor at the end of the message!” did you do that when you sending?If you did it mind be work.

2.After you upload some code you should reset the Arduino because restart GPRS module will get a high current that would effect our Arduino board.

Try again, thanks.

i haven’t reaced the step with the “Ctrl+Z”, when i send AT+CMGF=1 i never get “OK”. I have many times uploaded the code,pluged and unpluged the gsm shield and still i can’t get my OK.

the jumpers are in 7-8 position, the shield has the red light on and the yellow bilnking slowly(in the begining is bliking faster and after is changing).

thanks for your support!

1.As what I said, you should kick the reset button on the Arduino board to begin after you upload your code, not just pluged or unpluged the GSM shield.

2.Red light is power, D1 light blinking fast is select network after that found it and begin blinking slowly about 3000ms once time.

Try to use our example code to upload, it should work.

What if you still can’t send any SMS, give your code to us, tell us more detail.

Best regards


Here is the code i have uploaded without the gsm shield on it.

after i plug the shield on arduino, I reset the arduino, and i open the terminal. here what i get

i never get “OK” back. It stucks there!

if you want i can submit you a video with every move!

Hmm… I don’t get that “+PACSP: 1” line, when I power on my GPRS shield.
“PACSP” is “Network Selection Menu Availability”.

Do any other commands work? “AT”? “AT+CREG?”?
Is your SIM card active? Have you tried it in a phone?

But first – have you set line ending symbol as “carriage return” in your terminal program?