Problem with Arduinome


Few weeks ago i bought a 64 button pad from seeedstudio to mount my arduinome. I made my arduinome shield in my house. When i did test the shield with the button pad, only the leds did work correctly, the buttons didn’t work. I think the problem is in my arduinome shield.
Someone can help me? Someone had a similar problem?
See some pictures:



I’ll take a look at the pics and see if I can see anything.

did you try turning the cables for the buttons around, and try switching the cables just to make sure they are on right?

lost of people have problems with just the cable orientation

Yeah in the pics it looks pretty much like a copy of the unsped trace for trace, but make sure there are no bridges, sometimes they are there even if you can’t see them, and also like Atomriot said, the cables can be confusing, trust me I know :laughing:

Tnks guys for the replys!

I tested the traces with a multimeter, and I didn’t find anything wrong. I tried to switch the cables, but anything change. The leds blinks, I can write mensages, but the buttons don’t work :frowning:
Grrr, i will try one more time to have certain about that, if I have progress, I post about it here.


how are you testing it? are you doing it in max or are you doing it on a serial connection? you should see the button address and the button state message come across when you press a button when your attached to the serial port in the arduino ide.

did you try that?

At the time, I’am testing using Linux with Serial-PyIO.
To the Arduinome works, I need to open the Serial-PyIO and open the Arduino IDE and active the serial monitor, otherwise the leds don’t work too.

I realized that when i move the flats conected on the Arduinome Shield, strange messages appear in the Arduino Serial Monitor. See the Screeshot of my Arduino IDE and the Serial-PyIO:


Few minutes ago I tested again with the multimeter and i found no errors.

I don’t no what to do :frowning:


the “strange errors” are actually the byte representation of the numbers. sorry, i forgot about that part. if you change the code (temporarily) to output the byte number rather than the byte at that number, then you will see the numbers.

but, if you get values in the arduino serial monitor when you press buttons, it seems that the arduinome is responding somewhat properly.
did you flash the arduino to reset the serial number? Sorry, i am not familiar with Serial-PyIO

Yes, I flash the Arduino to reset the serial number to a40h-001. I used this tutorial:

the values do not appear when I press the buttons, the values appear when I pull out and put the flat cable in the Arduinome Shield. Because that, I think Shield is ok, and the problem is with the Led Button. You have photos from your Pad for comparing the placement of components?

Sorry, but I don’t have a good writing english :frowning:

Tomorrow I will try Arduinome with Monome Serial.



here is my photostream on flickr.

if you want a comparison photo, then take one and i will take the same or similar with my setup and post it.

My pcb is sealed in my enclosure so they might be hard to get but i will see what i can do.

actually, i see the issue. the buttons you have are wired differently than the all in one monome like buttons that i used.

check out this thread. page 2 has a graphic of your buttons vs the monome like all in one buttons that the pcb was made for.

I would never imagine that.
Just thought these were the same buttons that the other, but without the coating.
When I bought, I made it with my eyes closed. The staff of SeeeStudio have to tell the next buyer that these buttons do not work on the board. I bought these buttons because they wanted a cheaper alternative to mount my arduinome, in the end, it seems that will leave more expensive. :confused:

thanks atomriot for your help and patience.

I will try to solve this problem, go to work, hehe :nerd:

i know those buttons are still in the depot on the list, but when i tried to get some a few weeks ago, they sent standard push buttons without the led so I am not sure if they carry them anymore.

They do offer the correct buttons without LED’s so you can customize the color, but the cost is the same as getting the all in one buttons.

it is possible that you could jump the buttons so that they are correct. on the bottom of your pcb run a wire from the bottom right leg to the bottom left leg, but you will have to desolder the leg that is in the bottom left and remove it so it does not create a false contact.

otherwise, de-soldering those buttons and soldering the correct ones seems to be the only option short of getting another pcb.