Problem using Xbee shield v 2.2.

Hello everyone !

I am posting here because I can’t manage to make the Xbee shield v2.2 work with an Xbee Pro S1 module, it’s been now two weeks I’m trying, and unfortunately the wiki does not have much informations except a schematic and nothing I found on Google worked.

My final objective would be to make an Arduino UNO and an Arduino MEGA communicate with each other (It’s to build an RC car controller) using SoftwareSerial for at least the emitter (I need to stack an USB shield on top).

The MEGA is supposed to be the Emitter, but I might replace it with an UNO.

I configured both Xbee modules with XCTU correctly (Same PAN ID , same CH channel , MY Adress 1000 and 1001 respectively , AP mode disabled , DH set to 0 , DL set to the other module MY adress).

I also managed to make them work using XCTU terminal.

However , nothing with the Arduino IDE.

The lastest test I did was this :
XBee > Shield > Arduino MEGA > Computer > XCTU.

XBee > Shield > Arduino UNO > Computer > Arduino IDE (COM terminal)

I used this code taken from Arduino website to send messages through Serial :

[code]#include <SoftwareSerial.h>

SoftwareSerial xbee(2, 3);

void setup()
Serial.println(“Program started …”);

xbee.println(“Hello world ?”);

void loop()
if (xbee.available())
if (Serial.available())

And uploaded an empty file to the Arduino MEGA, to use it with XCTU.
But it doesn’t work, neither the UNO nor the MEGA receive anything at all. (I made sure the jumpers are in the right positions. Also , I do not know if it matters, but both modules are End Devices)

I also tried with hardware serial (Used Serial), I even tried with standalone 9V powering both Arduinos , without success.

Both XBee ONLY communicate through XCTU.

I’m completely out of things to try short of trying with another shield. :frowning:

Thanks for your time and don’t hesitate to ask for more informations.


On Arduino mega you can also use software serial port.

Not all pins on the Mega 2560 support change interrupts.

In this case, please disconnect all the jumper hats of XBEE shield, use two jumper wires connecting XBEE_TX and XBEE_RX to D10&D11.

Then modify the demo to SoftwareSerial XBee(10, 11); // RX, TX

See whether this works. Thanks!


I’m already aware of the MEGA’s pin not supporting change interrupt.
That’s something I forgot to mention, sorry.

I already tried with the correct pins on the mega, without success.

However, when you told me to use jumper wires, shouldn’t using jumper caps on D10 and D11 be the same thing ?
They can go up to 13.

PS : I had a problem with my account and cannot connect to it anymore, nor do I receive Seeed’s email.

Thanks for your help !