Problem uploading firmware to RFbee with UARTSBee V5


I have problem to upload a new firmware to my RFbee (V1.1 / V1.2) using UARTSBee V5.
when avr-dude try to send firmware, I have a Sync problem.

I have installed latest FTDI drivers on Windows Vista.

UARTSBee power switch is set to 3.3v
I’ve tried second switch to Prog position (Mesh Bee position ?) and the other position with no succes.

Firmware as been compiled using Arduino IDE configured for “Arduino Pro Mini/pro mini” with Atmel168 3.3v 8Mhz and programmer set to AVRISP.

I’ve tried to manually set serial port to 9600 and 19200 (and other various baud rate) in avr-dude command line. I’ve tried some other programmer set, but I always have a sync problem.
I’ve tried to use 3 different usb cable too, but with no luck.

AT commands are still working fine, but I can’t upload firmware.

Any clue on what could be wrong or missing ?

I’ll try to upload firmware using Leonardo&bee board as ISP programmer, but I never did it before.


I finally found how to upload custom firmware to RFbee using UARTSBee.

I had to set Arduino IDE with :
card type : Lilypad Arduino
processor : ATMega328
Programmer : AVRISP

In this configuration upload baudrate is set to 57600. (if using ATMega168, baudrate switch to 19200)

It’s not really what is said on seeeduino wiki, but till it works I don’t care.


Ok I should have started by checking this.
Looking at my RFBee V1.2 uC, I seen I have an AtMega 328 (not an AtMega 168).
It explains why I had problems trying to upload firmware.

It’s weird that this version is not visible on Seeed market place.
It seem’s I have an official Seeed studio RFBee V1.2 from 25/12/2013.


Sorry for the delay reply, seems that you had solved the problem yourself.
Yep, the mcu had changed to Atmega328 at version v1.2.
And please accept my apology that we hadn’t make it clear in the wiki.