Problem over multiple odysseys (5 + devices!) :BIOS looping of Odyssey Blue J4125

Hello Seeed Studio,

I work at a startup that uses the seeed odyssey blue J4125 126 GB as the brains of imaging systems in industrial greenhouses. For the most part it has been a great single board computer with the required resources for our application. It fits the sweet spot of an upgrade from a raspberry pi, without costing significantly more.

One of the largest pain points that we have been having is that from time to time the device is unable to boot successfully. It stays on the seeed studio bios screen (the blue one) and often shows the bios code 9c. I have tried googling american megatrends bios codes but have not really found anything. We have also upgraded the bios using the instructions on the website, but have still experienced this bios loop.

The only way to recover from this problem is either hit the power button and try restarting again.
Most of the time this doesn’t work. We then have to remove power from the board and temporarily remove the RTC battery. Generally after plugging both RTC and power back the system starts again, after some intermittent powering on loops. if this happens at clients, we need to go there to go through this process, something that we would preferably not do.

Relevant details on our use case:

  • the odyssey always has power, so there are no sudden power failures
  • there is a powered usb hub attached to the front usb3.0 A port
  • During normal operation at client, the system shutsdown normally through the Ubuntu 20.04 through the bash command sudo shutdown now

In our workshop one thing that we have noticed is that if the power is abruptly cut from the system, the chance of a bios loop increases, but this doesnt happen in the field …

What next steps can we take to minimize this effect?

thanks in advanced!

Hi there…
How are you powering the unit?
Power DC Jack 5.5/2.1mm or USB Type-C PD
DC Jack: 12V to 19V
USB Type-C: 15V
If yours is a loaded unit, try more power , power supply is key ,Some of the processing on a Celeron’ish chips really sucks the juice(like a brown out). Your doin imaging? Yea I would try that.
my .02
GL :slight_smile: PJ

have you ever measured your power supply going into the UNIT/ amps and Volts DC?
I would be keen to know what the req’s are under window and Linux I’m betting they are different too.


We have the same situation, we also use Linux, and from time to time it hangs during bootup, we use the device in heave machines Telematics, running 16 hours day, so when it hangs in the morning they loose one day… If you find out the issue please let us know. Only change is power cycle, reboot. We use the 12V from the vehicle, we also tried to add DC/DC, 9-36V in-15V out, 3A max current draw so should be enough.

@PJ_Glasso We are powering it through the power jack at 12.5 volts.
Your point on the brownout makes sense if we were to see issues when the OS is booted and running our program.
The issue that we are having this problem even before the OS has booted, so our imaging has not even started yet …
We also have powered usb hubs, but since they are powered they should not be a significant load on the Odyssey itself.

Hello, I have tested this morning on the desk, also the same before image is loading. We supply with 15V DC jack, measure the current flow, to the board, it´s usually peaks at +500mA for a short time during boot ( We use separat power supply that can deliver 10A at 15V), when this happens ->not loading, it´s steady state at 300mA, so we are even thinking about building a circuit board, that detects this peak current flow at bootup, and switch off the external supply and reboot again. We use the setting in the bios to “always on” so we do not use the power switch.

@Developer100 that is an interesting find! Have you seen if updating the bios firmware has any influence on this behavior?

Hi there,
OK I see so It’s not during the use but whenever it’s booted or powered up initially.
To me sounds like a bios issue or loading from the CMOS. Is it being POWER-On reset for cpu?
If you have access to a o-scope hang a probe on RESET line see what it looks like(clean system reset and power on reset pulse) Other than a bios upgrade that’s been suggested.
How do the units look inside? Look at bottom of PC board anything Sloppy solder wise? There QC isn’t the Best in the Industry by a long shot.
Have You tried a Higher PS voltage ? like the 15Vdc input?

Have you tried to clear the cmos or boot without the RTC battery?
What boot options are you using? I see you posted it’s an Ubuntu Linux, check this out?
Turn OFF fast boot if you have it on? The cmos may be of poor quality and lower speed this can effect the boot quality. AFAIK.
GL :slight_smile: PJ

Thanks @PJ_Glasso, I will get back to you ASAP!

@Bruce.Qin do you have any idea what may be causing this ?? All odyssey’s that i have bought have displayed this behavior at least once and we have used about 15 odysseys at this point.

Could there some type of protection that is being triggered ?

@Bruce.Qin I think we have +50 devices, all have shown the same. We have tried to update bios as well as controller. It is a blocking point for us.

@Bruce.Qin have you had time yet to look into this issue?

@Bruce.Qin this is still an issue an has lead us to start phasing out the odyssey for a more industrial computer that doesnt have this issue

Sorry, I just came to this topic. Can you make a video for me?