Problem on startup

Just received my new DSO QUAD. Hdwe V2.81 with SYS VB1.62, APP V1.13, FPGA V2.81. Everything was going fine. Able to connect to PC and read all files. Was reading a PDF file and hit a key it didn’t like (?). Now the PC will not recognize the unit when plugged in.

The unit starts up OK on it’s own and I can look at the gen output OK. Strarting with Run/Hold down and powering on the PC sez “unrecognized”, the screen on scope comes up with screen indicating S/N, license #, device firmware (V3.40C).

Tried a WIN 7 PC and still won’t recognize the DSO.

Anyone have pointers on how to troubleshoot this one? I suspect the DFU has been corrupted, but that is a wild guess.


If the device is starting up, displaying start up screen messages, and acting as a scope then it is somewhat unlikely that the DFU is corrupted. If it was badly corrupted then it wouldn’t start up at all, or display serial number etc.

Now it is possible part of it has got corrupted so that the USB disk emulation is not working, but it fairly difficult to corrupt the DFU by any normal activity. The main reason why this critical bit gets damaged is loading new firmware that has not been linked correctly so it overwrites the DFU memory area.

The two other main reasons why the DFU would not be recognised when plugging in would be a problem with the USB cable or an issue with the host PC DFU driver.

It is certainly worth trying a different USB cable and the other USB ports on the PC. Even if you think the cable is OK then it could be the battery charging current that flows down it causing a problem.

The host DFU driver can cause issues and people routinely struggle a bit on Macs, Linux and late Windows OS like Windows 8. You say you have tried Windows 7 which does not normally cause a problem but it might be worth trying running virtual Win XP if you can.

Before contemplating flashing a new DFU via the serial port method I would take a dump of your memory (see fldump utility near end of DSO Quad Boot loader corrupted thread. If you can find an owner of same hardware to do the same dump then you can compare the first 16KB which is the DFU. They should differ only in a few bytes where Licensing gets stored.

Thanks for the reply bobtidey.

I tried a new cable and still the same. Looked at the fldump utility mentioned but I would have to be able to upload to DSO, correct?
Since I can’t see the USB drive no transfers can occur.

Only recourse I can see is trying to dump via the serial interface but then I have to find a copy of the V3.40C firmware.

I have to mention I haven’t played around with coding since the 70’s and now microcontrollers, it is a new world. Will try muddling thru this.

I downloaded the STM flash loader demo app. I can try and see if I can get that working.

I was able to dump a hex file of the first 16K using the serial interface. Now does anyone happen to have a good hex dump for V3.40C firmware?