Problem:Flash DSONanoV2 with BenF 3.20 FW on Ubuntu and WIN7


I am trying to flash my DSO Nano 2 with BenF firmware. Initially I have tried on my Ubuntu 10.04 (64 bit) with a software called dfu-util which I have installed from synaptic.
No luck there with the commands

cd path_to_firmware_dir dfu-util -d 0x0483:0xdf11 -i 0 -D DSO_BenF_LIB_v3.02.dfu dfu-util -d 0x0483:0xdf11 -i 0 -D DSO_BenF_APP_v3.20.dfu

[code]dfu-util -V
dfu-util - © 2007-2008 by OpenMoko Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util version 0.1+svn[/code]

After reading on the dfu-util page it turns out that may be this software is working only with their bootloader so this may be the reason it is not working wth DSO nano DFU files (although DFU is standard protocol) … anyway.

Next try:
Windows 7 (64 bit)

Initially it was able to autoamtically install the driver! But when I have started the DFU Demo - the dropdown list where the currently connected devices shall be located is empty.
I have then read the manual and I have manually installed a driver for the DSO Nano that is attached on the USB - so the driver is the same the DFU Demo expects.
I have restarted the system and again tried DFU Demo - again it is not able to see the DSO Nano.

So I am now stuck - no way to update the firmware.
Any ideas?

The official dfu-util does not (yet) support ST dfu files (DfuSe). You can try my dfu-util version which has experimental support. See the thread viewtopic.php?f=12&t=1353 especially the recent “Build instructions” post.

Hi Tormod,

I have copied the git repository locally and I guess I have to build it now and install it.
I am not very experience in the git world and gcc … I guess I have to configure it and then call
sudo make install … is there so page that decribes how to get dfuse-dfu-util up and running?

I have tried to switch to the dfuse branch

git checkout dfuse

but git complains with this error:
error: pathspec ‘dfuse’ did not match any file(s) known to git.

one more edit:
I have tried

cd dfuse-dfu-util

And it complained:
./ 4: autoreconf: not found

I have searched for autoreconf in synaptic and found autoconf2.13 (which is obsolete) then the autoreconf was found but this time different error appeared

Can’t exec “libtoolize”: No such file or directory at /usr/bin/autoreconf2.50 line 189.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf2.50 line 189. installing m4/install-sh' installing m4/missing’
src/ installing `m4/depcomp’

okay, lets go with the edits :slight_smile:

I have removed autoreconf2.13 and I have installed autoreconf2.65 … when I ran


I got

Can’t exec “libtoolize”: No such file or directory at /usr/bin/autoreconf2.50 line 189.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf2.50 line 189.

After some more digging I found out I had to install libtool



is Okay, so I believe I have to call


And I get this error:
configure: error: *** Required libusb >= 0.1.4 not installed ***

Now searching for libusb

Strange, I had libusb0.1.4 installed on my machine, but I had to install libusb-dev and finally


is fine!

Now type in make


I cannot believe my eyes! I have


Now, lets see whether I will be able to flash the DSO Nano V2 with the --dfuse default option :slight_smile:

last edit for today:

../dfuse-dfu-util/src/dfu-util --dfuse default -d 0x0483:0xdf11 -i 0 -D DSO_BenF_APP_v3.20.dfu
../dfuse-dfu-util/src/dfu-util --dfuse default -d 0x0483:0xdf11 -i 0 -D DSO_BenF_APP_v3.20.dfu

both say:

dfu-util - (C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Segmentation fault

Hmm, did you really read that “build instructions” post from today?

You need the libtool package as well as the autoconf package. This stuff is needed when building from git, to generate “configure” etc. Then in a release tarball, a “configure” is usually included so that it can be built without all this stuff.

I am afraid I can not do this for each time I update the git repo, but I have made a Ubuntu package of it right now which you can download from
Just download and install the right .deb package. It should install fine in Ubuntu 10.10 or Debian unstable as well.

Therefore no dfuse support and the program crashes… Like I wrote in the build instructions you will have to use git checkout -t dfuse if you have an old git client. If you get an error, very likely something will go wrong later.

To sort out all the build dependencies (I should add this to the build instructions):

sudo apt-get build-dep dfu-util

Stupid me! I have read the thread, but fail to notice the little black sentence at the end of the page that says that there are more pages …

Thnaks tormod!

I have followed the instructions and successfully build your version of dfu-util and successfully preflashed BenF firmware.