Power problem, unit is "dead" (Odyssey X86J4105)

I have a Odyssey X86J4105, the version that was delivered with an 128 GB SSD (not eMMC) and the blue case, and it will not start.

My questions are:

  • Is there a way to reset/bypass/force the Odyssey-internal power converters to turn on?
  • Is there something else that can be done to get the Odyssey to turn on when it is supplied with 12 V?
  • If not, how does the repair flow work?

And also, which is the closest equivalent to my unit, in case it is not possible to repair? Is it this one: https://www.seeedstudio.com/ODYSSEY-X86J4125800-p-4915.html (SKU 102110539)?

This is the background:

The first indication was that the supplied 12V/2A power supply delivered less than 2 V, while disconnected from the Odyssey, so that supply is obviously broken.

I then connected the 12 V from a 250 W computer PSU, which can deliver > 10 A on the 12 V rail. When I pushed the power button, the blue LED lit up for about 3 seconds, during which the voltage on the input dropped from about 12.3 V to about 11.5 V (and from this 10+ A power supply, it means a large current went into the Odyssey, but I did not measure the current itself).

And then, after pushing the power button a few times, it did no longer even try to start (no blue light at all, and no voltage drop on the 12 V input).

I disassembled the unit, but saw no visible damage, no metallic shavings that caused a short-circuit, no burnt components. I also removed the heatsink, noticed way to much thermal paste, but that did not appear to be the problem either.

I did measure about 3.2 V at the test points near the power switch, which means that 12 V enters the device, and some low-level control voltage converter is active to supply the power-up logic, so it is not the input connector that is broken.

Without schematics of the board, I have no way of doing anything more right now.

You can remove the BIOS battery for a while the try again.
@lakshan Pls support it.

Hello @seeeder,

Did the product work out of the box or did the problems start to appear after using it for a while?

Thank you.

Hi. I did remove the BIOS battery, let it sit undisturbed for a while, reconnected the battery and plugged in a power supply. It then seemed to behave correctly, and it even booted up.

So problem solved? The fact remains that for a while, it did not react to pressing the power button at all, as I wrote above. Perhaps there is a self-resetting fuse inside the Odyssey that had tripped, and needed some time to cool off?

@lakshan : The unit worked fine for about a year or so. It seems to be up and running again now. But even if it seems to work now, something caused the original power supply to break down, and I can’t tell for certain if the problem was in the external power supply or in the Odyssey itself.

What is the normal current that this unit consumes from a standard 12 VDC power supply, both when completely turned off and during the bootup phase? I measured about 30 mA when off, about 600 mA immediately after the power button was pressed, is this normal?

Hi @seeeder ,

The currents you have mentioned are completely normal. I am not quite sure what your problem is now. You have mentioned that you can now successfully boot the ODYSSEY.

Please help me clarify. Thank you.

It works now, so right now I don’t have any problem with it.
It did not work for a while, as I wrote in the original post. So whatever the problem was, it does not appear for me now.
(Except for the first power supply, which broke down but I have now replaced that one.)

No futher help is needed on this issue.