Possibly faulty Grove BLE (dual model) board?

My problem is with the [Grove Bluetooth module (dual mode)](https://wiki.seeedstudio.com/Grove-BLE-dual_model-v1.0/)

I suspect the module might be faulty - I just want to confirm with someone what I should expect in terms of results, so that I can rule out the possibility of user error.

What I did

As I understand it, the HM-13 should be in AT mode by default (like the more common HM-10, and I guess, 11 and 12). Sending “AT” does not return anything from the module.

I followed the instructions from Seeed exactly. I even tried foregoing use of the shield and manually wiring the module up to my Arduino, trying different example code, and different pins. I even tried not using the SoftwareSerial library and wiring directly to the TX / RX 1 / 0 pins.

To send the commands, I used the Arduino IDE serial monitor, as well as some linux software called “CuteCom”. In all cases the TX / RX LEDs on the board light up but I never get a response.

Some questions

  1. When scanning for Bluetooth devices with my Android phones (7 & 10), I see 2 HMSoft devices. I’m assuming one is for EDR mode and the other is for BLE mode?
  2. Should the board respond to AT commands when in Slave or Master mode?
  3. Assuming I connected the pins correctly, the board should respond to a simple “AT” request? In the docs, they use Windows software to send the commands, but I assume I can also do this from the Arduino IDE?
  4. How likely is it that my board is faulty?
  5. If I connect with my Android phone, the LED on the BLE module stays on - but pressing the button for more than 100ms as stated in the documentation, does not reset the connection - the LED stays on. Is this normal?

Thanks, and happy holidays!