Overview over HW version, FW version and so on

Hello DSO Quad World

I just received my new DSO. It tells me “Hardware ver 2.60”, “Sys Ver 1.51” and “App Ver 2.52”.

After looking at the forum, I am somewhat confused… I’m looking for a firmware with as few bugs as possible and, if possible, X-Y mode. Which one shoud I use?

  • It seems that the “engineering firmware” version 2.53 an has X-Y mode, but the link to it in the WIKI points to an App dated 6.1.2011 and Sys dated 29.12.2011, can this be the “newest” firmware? If not, where do I find it? Does it correct all known bugs?
  • How good is the firmware of “marcosin”, does it keep the complete originial functionality of the DSO, adds more and corrects bugs?
  • Can I use the two files of marcosin (app and sys) with my FPGA version (it seems it needs 2.22 and I have no idea what I have)?
  • Which is newer, FPGA version 2.5 or 2.22? (22>5… or does 2.5 mean 2.50…)
  • How good is the firmware of “chip” and where do I find an actual version?
  • How complete is the functionality of the firmware of “gabonator” with the new nicer gui? Is it suitable for general use?

By the way, does “Hardware Ver 2.60” mean 2.6 or could it be 2.7B too?

Thank you for your help!

I have a related question. My firmware wasn’t that up-to-date, it was 1.50/2.51, so I tried to update it following the directions given in the “quick guide for updating firmware.” My system now says it’s 1.51, 2.52, and 2.60. I’m not sure if the FPGA update went correctly or not, since no version number changed, even though the version on the FPGA firmware is 2.61. Is this a problem in the update, that the version number doesn’t change? Perhaps I screwed up? Is there a definitive way to determine the FPGA version other than that screen that flashes by so quickly that if you blink you miss it?

I tried to send an email about this problem to your support department and got a message back saying that my email was rejected as SPAM because it comes from a provider that is a frequent source of Spam, comcast.net. I think you might need to make a few adjustments to that filter. :slight_smile:

I’d love to get started using my new DSO Quad, but I’m nervous about doing anything more until I’m sure I haven’t somehow messed up the firmware. Please reply quickly.


P.S.: I suggest you add a section to the “quick guide for updating firmware,” that discusses what can go wrong, the ramifications and how to fix it.


Is there nobody here to answer Ray’s easy question and mine?

I bought this small, exciting DSO after seeing that there is a very active community here… but now that I have received the DSO, it looks rather like if the community is brain-dead now, and the manufacturer not especially interested in correcting obvious bugs - and even less in implementing new functions (like X-Y mode).

I hope I’m wrong!!! Help! :neutral_face:


PS: I updated to firmware 1.8 from marcosin and it seems much better than the original one (thank you and congratulations!!!), but there are still obvious bugs like the 10x of the probes settings not working at all for me.