OLED Display 128*64 with Arduino Yun Doesn't work

Hi Seeed,

I have two separate systems with the following setup: a Grove shield on an Arduino Yun with an OLED Display 128*64 in the first I2C plug (the one nearest the analog plugs). Here is the problem: when I load up the “OLED_Hello_World” example nothing happens. The screens on both are dark.

These are new Yuns and seem to be working fine otherwise. I put a Grove Temp/Humidity Pro sensor on A0 and that worked great. The OLED displays don’t. I tried one of the OLED displays on a Xadow, and it works fine there, so I don’t think there is anything wrong with the OLED hardware.

Any idea what is going on?

The example code:

[code]#include <Wire.h>
#include <SeeedOLED.h>

void setup()
SeeedOled.init(); //initialze SEEED OLED display
PORTB |= 0x21;

SeeedOled.clearDisplay(); //clear the screen and set start position to top left corner
SeeedOled.setNormalDisplay(); //Set display to normal mode (i.e non-inverse mode)
SeeedOled.setPageMode(); //Set addressing mode to Page Mode
SeeedOled.setTextXY(0,0); //Set the cursor to Xth Page, Yth Column
SeeedOled.putString(“Hello World!”); //Print the String


void loop()


Same problem here.
Using Arduino Nano

OK, I feel a bit silly now! But as I can see others might get bit by the same oversight, here’s what I did wrong… :blush:

There is nothing wrong with the Yun or my code, I have been using Grove from Seeed Studio as a way of rapidly prototyping combinations of sensor for different applications. All great and fine, but I2C is not on the same pins on the Yun!

The Grove Base Shield I2C plugs can not be used when you use this shield with the Yun, though other analog and digital pins are fine. I wired a Grove I2C Hub to pins 2 (sda) and 3 (scl) and everything works great.

seeedstudio.com/wiki/Grove_- … hield_V1.3