Odyssey x86j4125800

I want to give my ODYSSEY X86J4125800 (TELEC no emmc) to my friend so I am trying to install Windows 10 on this before hand. I have downloaded Windows 10 from Microsoft web site, formatted and DD the ISO to a USB drive on Ubuntu. Booting into the installer, no hard drive is shown. It told me to select a folder to load some drivers. I have put all the drivers downloaded from SEEED and tried them one by one but no luck.

I am trying to install Windows onto NVME M.2 SSD (Kingston A2000). May I know if I need to set anything in the BIOS? What driver do I need so as to install Windows?


Can you see any disk in BIOS setting? It seems the boot drover problem. You can try to make a nother boot driver by Rerfus.

Yes I can see the M.2 SSD in BIOS and set it in “boot order”. I have Ubuntu installed on it. So I think it is mainly due to Windows installer problem? Tried Windows 10 and Windows 11 installation file.

By the way is installing Windows 11 possible on this machine?

Yes, support win11.
You can follow below link to restore windows.

1 Like

My machine does not come with eMMC. Will the “Original Windows 10 Image” allow me to install onto SSD?

Yes, the OS will be installed to the SSD.

WOW Using the provided zip file, the installation was automatic and fast! I wish I have found it earlier but not spending a whole night last night… Thank you very much for your help.

We have release Reserver with Gen.11 TigerLake CPU. You can take a look.

1 Like