Odyssey X86J4105 unable to load bios

Just received my Odyssey X86J4105 with 64GB eMMC. Trying to boot to bios by plugging in a keyboard and holding down delete key. Device does not boot in this situation. Tried 2 keyboards and all the USB ports without success. Booting normally goes to windows 10 without problems, and the keyboard works fine.

Any suggestions on how to get to bios? Any way to do it other than via delete key?

F7 as described in the manual

Apologies, didn’t mention that I used F7 first up after reading manual. Wont boot to bios with F7 either. I resorted to delete key after trawling through all the online documentation that seems to mostly recommend it.

@Scott_Williams were you able to figure this out ? I was too seeing this issue right after unboxing, where it boots to Windows 10 just fine, but if I try to get to bios, it just hangs. I have tried both Del and F7 keys, as well as trying the Windows recovery options to go to UEFI bios. Then I realized that it could be a display error, because it would just switch off the display when I should be in the BIOS.

Long story short, there was a HDMI compatibility mode in my LG display that needed to be turned ON. After that I was able to get into BIOS just fine.