Odyssey X86J4105 does not power on anymore

I bought an Odyssey X86J4105 with 64GB eMMC (and without the Windows license). First power on (original power supply) without any M.2 SSD attached went good - it booted into Windows 10. Then I unplugged the SBC from power, attached an NVMe SSD (PNY CS3030 1TB) to the PCIe x4 slot, plugged in to power and booted to a Linux live distribution from USB and the SBC booted fine and I could see the nvme0n1 device correctly. Then I unplugged it again from power, additionally attached a SATA M.2 SSD (Crucial MX300 M.2 1TB) to the SATA M.2 slot, plugged the SBC again to power and it did not power on anymore. I removed the SSDs, tried a different power supply - I cannot get the Odyssey board to power on again. The original power supply delivers the 12V and powers on another SBC that takes 12V, both the NVMe SSD and the SATA M.2 SSD work in another PC fine. The only thing I can see on the Odyssey board is that once I plugin the power supply and attach a network cable on either network jack, the orange LED on the RJ-45 jack lights up as long as the cable is connected and the greed LED blinks.

What’s up with the board? What can I do?

Please help - I have many SBCs since the Raspberry Pi 1(B) including several x86 SBCs (Lattepanda “original” and Alpha, Odroid-H2, Atomic Pi - also used M.2 SSDs and PCIe risers there, where applicable) but never had any problem like this.

Best regards
Michael

For what it is worth I had nearly the same thing happen to me. I installed Manjaro on an M.2 ssd. Upon reboot the screen quickly flashed with some error and powered off. Since that time the board won’t power on. Not sure how installing Manjaro would brick the board but it did. My board was the version with the emmc installed but disabled. Yes, i removed the SSD. Still bricked.

Hi Dave,

thanks for your posting! That sounds bad, too. Just to clarify: I did not install any OS on the SATA M.2 SSD, I just mounted it physically and wanted to boot from the USB stick again to continue my tests with the M.2 SSDs. From then on the Odyssey board did not power on, even after removing the M.2 SSDs and the USB stick.

Best regards
Michael

Hi @k.michl @DeveloperDave

Sorry about this, please could provide some pics or videos so that we can have a better picture of the situations.

Anson

Hi @ansonhe97

Thanks for your reply! :slight_smile: I have created an unlisted YouTube video. I would prefer not to post it publicly but cannot send you a PM because I am a level 0 user. Could you please send me a PM, so I can reply to it with the YouTube link?

Thanks & best regards
Michael

I realize this has gone to PM but for those of us who are comtemplating buying the Odyssey x86 it would be nice to know the outcome. Was this situation of not powering on fixed?

Hi @starman345,

not yet, because the outcome of the PM some days ago was to contact support, which I have done only yesterday.

Best regards
Michael

I have the Windows Enterprise model and have just had the same experience. I have been using for several days without any issues with a USB C Monitor with the supplied Power Supply. I just added a M.2 Sata SSD and it no longer boots. The monitor boots up for a few seconds then shuts down. I have tried to boot without the monitor. Same results. The power button is no longer lighting up.

Please help

Thank you

I had the same sort of issue last week. I resolved it by disconnecting the CMOS battery and the external power for a short period of time then reconnecting it and it booted fine after that.

My guess would be some type of BIOS error being triggered and wiping the BIOS data resolves it. I’m thinking mine was triggered by my monitor turning off which turns off the USB-PD power

2 Likes

Please remove your SSD and all power then reboot.

I have, the power but LED never lights and video is blank. No reaction to the power button or unplugging and plugging in the power.

It will not power on any more.

What is the next step?

Thank you

@geocom You -Da Man! Thx. 1234 to fill the character requirment

Can you power up the board now?

Hello,

I recently got the Odyssey x86J4105 and the same problem occurred. I installed Ubuntu 20.04 and about a week after that, without doing anything unusual, it stopped working.
The odyssey can’t turn on, the blue LED doesn’t blink, but when I connect an Ethernet cable the RJ-45 jack lights up.
I tried using different power suppliers, disconnecting the battery and the supplier for the weekend and it still doesn’t power on.

Thanks in advance

Hello @Foxman,

Can I know whether you bought this directly from Seeed Bazaar or a reseller? Your unit needs to be replaced.

Best Regards,
Lakshantha

Hi @lakshan,

Thanks for you reply! I bought it directly from Seeed Bazaar and I’ll contact them for a replacement.
Do you have any suggestions what can I do now to fix that issue?

Thanks,
Nadav

Yeah. Please send an email to support@seeed.cc.

If the board doesn’t turn on at all or there is no HDMI output, the problem might be with BIOS chip. Unfortunately you cannot fix it. Please mention in the above email that you have talked with me and I have come to the conclusion that the BIOS chip has problem and therefore board needs to be repaired.

Best Regards,
Lakshantha

Ok, I will update you with the results.

Thanks,
Nadav