Odyssey J4125 Won't Boot

I got an OS installed on the J4125, and played with it for a few minutes. Later, I tried to install another one, but the device simply won’t boot. The power light comes on, but the system is dead. Getting into the BIOS settings is impossible. There is no HDMI signal, no flashing lights, nothing. I’ve changed cables, monitors, and keyboards, but it just won’t do a thing. We’ve had the device for more than two months but for less than a year (it sat around for a couple of months waiting for someone to have time for the project.). Can we get it serviced?

Hello @RTESysAdmin,

Could you please reset the BIOS please by following:

  • Power off X86
  • Remove CMOS battery (yellow battery)
  • Wait a few minutes
  • Put back CMOS battery
  • Power on X86

Please let me know the result afterwards.

Thank you.

Thank you for your response, Iakshan. I tried that twice, waiting five minutes before reconnecting the battery and power supply. The result is the same. The blue power button light comes on, but nothing happens after that.

I hope you are well, Iakshan. I did everything you asked except those that required powering on the Odyssey because the Odyssey doesn’t power on no matter what I do. How can I get warranty support for this device?

Hello @RTESysAdmin,

Few last questions before we can move on to warranty support. Did you ever try to update the BIOS before? Also, did this happen just after you installed the new OS? And what OS did you install?

Best Regards,

Hi, Lakshan. I had intended to update the BIOS, but I hadn’t yet. I had installed OPNsense (a fork of pfSense, which is based on FreeBSD) just to look at it, and was rebooting to install pfSense when I discovered that the device would power on but do nothing on any peripheral port. The thing just died.

Hello @RTESysAdmin,

Please send an email to support@seeed.cc and order@seeed.cc mentioning that your ODYSSEY is not bootable anymore. Also, mention that you have already talked with me on Forum and I have concluded that the product needs to be returned because the BIOS chip probably needs a replacement.

Also, please share a video here when you try to boot up the board, highlighting the board with Blue power LED and display not working.

Best Regards,