Odyssey J4125 won't boot debian from USB drive


I’m trying to install Debian on a brand new Odyssey J4125 to run the Frigate NVR. I’ve tried everything and always wind up with a blank black screen with cursor. I’ve tried 3 thumb drives (they’re all quite old, but 512M, 1G, 2G), installing the Debian ISO from Windows and MacOS, using the Mac command line (hdiutil, dd), Etcher (mac), Rufus (Windows10). I’ve tried formatting with FAT (Windows) and FAT32 (Windows & PC). Booting from generic USB device name, UEFI partition 0, UEFI partition 1, from both the BIOS booter and from shift-Reboot under Windows10. I’ve tried the Debian netbooter iso (~450meg) and the DVD iso.

I’ve been making bootable USB drives for Raspberry Pis since the B board. I’ve read lots of pages about UEFI boot requirements.

What should I try next? I must be missing something really dumb. It can’t be this hard to install Debian.

Thanks, at wits end,

@jkalucki pls update the latest firmware( BISO and EC), press DEL key enter the BIOS then select your USB boot device as first boot.

I can’t find firmware for the J4125, only the X86J4105 at Updating Firmware - Seeed Wiki.

My J4125 has BIOS SD-BS-CJ41GG-300-101-K… from 05/20/2022 17:09:09. The EC version is 02.0E.0B(P0). TXE FM is GOP is 13.0.1018. Is this the latest firmware for the J4125? My firmware doesn’t line up with any of the older versions on the website, so it’s hard to tell if I have the latest version.

Is there a reason to suspect this firmware is the problem?


@jkalucki This firmware is compatible with 4125/4105.

Hi Bruce,

I can’t get the J4125 to boot the firmware updater either.

I’ve tried two different USB drives, both MBR and GUID, booting to both the device name (i.e. Generic USB Flash Drive) and to the UEFI: (Generic USB…), Partition 1. The first just hangs with a black screen. The second takes a second but returns right back to the “Please select boot device” menu.


@jkalucki No need MBR or GUID, just format the disk and put the file to the disk. You can follow the instrustions.

@bruce.qin Thanks for your help. I updated the BIOS but it didn’t help my problem.

The issue was with the Debian ISO itself. Apparently this processor cannot boot i386 32-bit linux. The AMD64 64bit ISO works fine and boots right into the installer. I’ve only been working with ARM Linux for the last 10 years, I had no idea that Intel 64 bit processors also used the AMD64 architecture.

:grinning: :grinning: :grinning:Have a nice day.