NPi i.MX6ULL Dev Board can not connect

Hi,
I recently bought the NPi i.MX6ULL Dev board and I can’t connect via OTG. I am following these instructions on the wiki. https://wiki.seeedstudio.com/NPi-i.MX6ULL-Dev-Board-Linux-SBC/

  • The dip switches are in the correct position (2-5-8)
  • The image was flashed correctly to the sd card
  • I am using a usb c cable with the data pins (I’ve tried a few different cables to make sure)
  • I’ve tried connecting it to both my Linux computer (Fedora 32) and my Windows computer (Win 10)
  • The power LED is on, and the heartbeat LED is flashing like a little heart beat

But no new device shows up in either Windows or Linux.

The only thing which I can see is different is the size of the image. The “imx6ull-debian-buster-console-armhf-latest-2gb.img.xz” image is about 100MB when compressed, and about 300MB when decompressed. The image on the wiki showing Belana Etcher shows the image there is 1.78GB. I guess this is fine and you’ve just updated the image, but it’s the only difference I can see.

Any ideas or clues what I can do?

Thanks.

1 Like

Hi, @sucseeed :
thanks for your feedback. and we got this error.we will contact you after fixed the error of USB OTG. It is also very convenient by using TTL UART to access the NPi i.MX6ULL Dev board.

I have been unable to access the TTL UART. I have an 5v FTDI board connected, I see the serial port in windows, but I see nothing in Putty when I connect.

My board came with an image in the EMMC which boots and I can access using the USB C serial port. Interestingly enough, the heartbeat LED is on solid but I can still get in.
When I boot off an SD Card flashed with the latest image, the heartbeat LED starts flashing, but I can not connect using the USBC serial port (never shows up in windows) nor the TTL port through a 5v FTDI adapter. I am frustrated because I am having trouble configuring the second network port.