Not able to install Seeduino Xiao driver on my window 7 computer even thought following the direction

Hi, I am not able to install the Seeduino Xiao driver on my window 7 computer. even thought following all direction for Arduino IDE. Any suggestion to get a driver for window &? Thank you in advance.

Sorry Window 7 Microsoft has stopped maintaining, no one wants to be responsible for its stability, we have no way to support it.

thanks for your response!

I have had problems with talking to the Xiao with Windows 7 on two machines both using IDE version 1.8.13. Both exhibited the same issue and the same solution worked.

On plugging the Xiao into a USB port it would appear in Device Manager under Other Devices rather than under COM Ports. To me it suggested that the correct USB driver was not available. Trying the FTDI one as recommended did not seem to work.

My solution (by experimentation) …

Right click on the wrongly placed entry in Other Devices and right click to select update driver.
Follow the following screen prompts : -

“Browse my computer for driver software”

“Let me pick from a list of device drivers on my computer”
(You might get a list of driver types so slide down to and select Com Ports)

“Select driver you want to install on this hardware”

Select Arduino LLC in the Manufacturer window

Select SmartEverything Fox bootloader and Enter (this is at the bottom of the listing)

Click to agree that you accept this regardless that it might be wrong etc

Device manager should now have moved the Xiao into Com Ports from Other Devices

Note the Com Port number that has been allocated.

Open the Arduino IDE and make sure the Xiao is showing and that it has the new Com Port allocated.

Go to “Get Board info” and you should get a small window response back suggesting it is now talking to the board OK.

Load a program such as Blink which should run and edited versions should also load.
Note on one of my machines I get an error message but it still seems to have loaded OK.

I have no idea why this works but SmartEverything appealed to me as a good driver name to try …


1 Like

Hi @Coxworld,

Even though this seems like a workaround, we do not recommend doing it. As @Baozhu has mentioned before, there is no official driver support for windows 7 and we are not responsible for the stability of the driver that you have mentioned above, since it’s not an official driver for XIAO.

Best Regards,

I understand what you are saying BUT the XIAO marketing department are missing a huge aspect of this. You have brought out an amazing device that has excited the experimentation fraternity, a fraternity that gives such devices popular support and exposure to increase sales. The majority of these experimenters will be using their old machines for their experimentation work, machines that will be running on XP or Windows7. Not seriously looking after this fraternity is a major error.
Think again !

1 Like

Great answer. Your solution worked for me ( windows 7 upgraded to windows 8). Which library and bootloader are you using please ? Thank you.

Hi Phil, hmmm long time ago that I posted and have since had to upgrade to Win10 on all machines to be able to use Fusion 360 CAD/CAM. I was using Arduino IDE but now on Sorry I am not being much use.


1 Like