Node using XIAO_nRF52840 and Grove-LoRa-E5 running on AT commands, sleep current 6.4uA

Using a XIAO_nRF52840 as the host controller and a Grove LoRRa-E5 as the LoRa module, I investigated how low the sleep current could be when a node was configured using AT commands only. I hope this will be helpful to those interested.
The configuration is shown in the figure below, with 3.6V supplied from a PPK2 to the battery pads on the back of the XIAO, and 3.3V supplied from the 3V3 pin of the XIAO to the VCC pin of the LoRa-E5. The LDO of the LoRa-E5 has been removed to supply the 3.3V.
As an example, a 10-second sleep sequence after transmitting 10 bytes at a frequency of 922.1 MHz, a spreading factor of SF7, a bandwidth of 250 kHz, and a transmit power of 13 dBm (20 mW) showed that the average sleep current during 10 seconds could be reduced to 6.4 uA. My previous experience with XIAO’s LightSleep current was 4.7uA, and the LoRa-E5 is known to be down to 2.1uA according to the datasheet, so 6.4uA was almost exactly what I expected. The average current per cycle, including the transmit period, was 614uA. This varies greatly depending on the spreading factor, bandwidth and transmit power settings.

What I have done to reduce the sleep current…

Remove the LDO and use 3.3V power supply since the quiescent current of the LDO is as high as 65uA
“AT+TEST=STOP” to turn off the radio and “AT+LOWPOWER” to make it sleep

Use “Seeed nRF52 Boards 1.1.1” for BSP and use LightSleep mode delay()
Use Reg1 as DCDC mode
Put on-board flash memory to sleep
Disable UART port during sleep period

The sketches used in the experiment can be found here. (2.8 KB)

The following link is helpful regarding the sleep current of XIAO_nRF52840.
Sleep Current of XIAO nRF52840, Deep Sleep vs. Light Sleep - #2 by msfujino
XIAO nRF52840 Battery voltage reading circuit increases sleep current

Excellent and well Done! :clap: The Lora Folks are gonna love that!
My question is How Far can it go? any test data on that? or does it only have to reach a gateway and ride the Al-gore Network the rest of the way or What?
very good stuff, and very much appreciated too.
GL :slight_smile: PJ

Hi PJ,
I plan to experiment with point-to-point communication using two nodes.
In preliminary tests in a residential area with poor visibility, communication was possible over a distance of more than 500m on the ground.

1 Like

Hi Msfujino,
I have not gotten any Lora stuff yet, but wow that coupled with some local BLE would be a nice 1-2 punch. short and long range. :+1:
What kind of data rates we talking?, is it a Full duplex connection? Well It’s xmas so maybe Santa SEEED :santa: will bring a couple Grove-Wio-E5 Wireless Modules under :stuck_out_tongue: the tree or even An E5 dev board in the Stocking…LOL
I recently went for a nRF52840 Dev board and going to dive into the SDK eventually, Also I like the cheapness of the Xiao ESP32C3 and the Flash Expansion on the Grove board gives it additional Memory available without a shoe-Horn, the low power will need a look into, but nice option.
You have a merry Xmas. :christmas_tree:
GL :slight_smile: :v:PJ

Santa Claus arrives early and all the lab equipment is ready to go.

1 Like

LOL, :smile: :ok_hand:
Now we are talking…WOW, Hilarious I have recently up’d my RTL game to TWO (2) for Trunk tracking radio signals .
SDR-sharp’ish :wink:
Man You sure we are not related?
GL :slight_smile: PJ :santa:

Maybe we’re related.
I have been using SDRsharp for years to listen to aircraft radio, and the following software is useful for viewing LoRa spectrum.

1 Like

Point-to-point communication was possible between 3.5 km of viewing distance.
RSSI=-106dBm, so it seems that the distance can still be extended.

Transmitting 10 bytes, 922.6MHz, SF12, BW 125kHz, TxPower 13dBm, antenna 165mm

Did you do something eles than remove LDO and connect two pins?
I do same, and after this my grove module stop working.
When starting it take 7mA and don’t react to AT commands :confused:

I checked twice, and VCC on grove pin have short to VCC on LoRa-E5-HF

Did you connect it the same way as in the setup in post1?
In particular, are you sure that the power supply to the grove is 3.3V and not 5V?

yes, exactly same.
I have very good in my “lab” power suopply. I exactly set it to 3.2V (lora-e5 should support from 1.8 to 3.6).

But I connect LoRa-E5 to my laptop via usb-serial with logic 3V3 … of course I connected GND to power supply and usb-serial

But I connect LoRa-E5 to my laptop via usb-serial with logic 3V3 … of course I connected GND to power supply and usb-serial

Can you please illustrate exactly how the connections are made?
Is the sketch you are using the same as the one attached in post1?

now I made exactly same connection as post1… only diffrents is that I use esp32s3-XIAO powerd from usb-c… rest is the same.
Maybe I damage something when i removed LDO using hot-air.

As I am sure you know, the sketch in post1 does not work on the ESP32S3.
Is your problem now that LoRa-E5 no longer works with AT commands?

for now LoRa-E5 don’t make any power consumption so I gues it don’t start.
Also when I try to send some AT commands, then is nothing recived.
I will try to re-add LDO in a few days.

Also I order few more LoRa-E5 gorve module… when I recive it I will try to remove LDO from one more.

I will return after my test.

BTW… Thank you for your quick response. :slight_smile:

1 Like

Hi there,
What kind of soldering device is in use here? WOW :face_with_peeking_eye: that’s not going to fly blobbed up like that.
More flux less solder may help too.
GL :slight_smile: PJ :v:

1 Like

I think I found the problem… I just throw up few my “crocodile clip cables”… one of broken I used to connect GND… there sometimes working, somtimes don’t.
I don’t know if this do some impact to my chip.
Now I tested on working cables, but still not working :confused:

At tuesday I will recive new modules… then I will combak with feedback :wink:

1 Like

Is it possible that the reason for not responding to AT commands is that the baud rates do not match?
Is LoRa-E5 in “4.30.1 Low Power Mode”? If so, you need “FFFFFFFF” before the AT command.