No sensors detected on raspberry pi zero W 2 - "Check whether I2C enabled and Grove Base Hat RPi or Grove Base Hat RPi Zero inserted"

Hello team, I have setup my raspberry pi zero W 2 with raspbian legacy and followed the hat setup instructions but none of my 4 senors (4 digits display on D5, button on PWM, 6 axis accelerometer on I2C, GPS air 530 on UART) are detected althought i tested the ports and the gps led is blinking.

I checked i have an ST chip on my hat and modified the three files with 0x04 but it didn’t change anything.
How can i finally get these sensors to work ?

The most likely reason for this problem is that the library used may be out of date,To operate the grove sensor, relies on a number of hardware interface libraries.One-click installation, quick start, what ever you call, with the single command below, we can install/update all dependencies and latest

curl -sL | sudo bash -s -

In additon,there have another way: Step by step installation

git clone
# Python2
sudo pip install .
# Python3
sudo pip3 install .

i hope my advice can solve your promble

Thanks for your quick answer. The installation seems to have gone well (unless “git clone GitHub - Seeed-Studio/ Python library for Seeedstudio Grove devices” which was unable to run due to already existing but unfortunately after restarting the pi the i2c is still empty and


is still answering me “Check whether I2C enabled and Grove Base Hat RPi or Grove Base Hat RPi Zero inserted”

I am desperate to solve this problem, have you any ideas or is a switch to arduino/raspberry pico an idea to consider to record csv data from my sensors ?

Maybe it’s a matter of how you use it? you can use the Grove Base Hat for Raspberry Pi Zero with dozens Grove modules, tap the command grove_ and press the key tab to check the supported Grove list.

pi@raspberrypi:~$ grove_
grove_3_axis_compass_bmm150        grove_i2c_color_sensor_v2          grove_mini_pir_motion_sensor       grove_rotary_angle_sensor          grove_temperature_sensor
grove_4_digit_display              grove_i2c_motor_driver             grove_moisture_sensor              grove_ryb_led_button               grove_thumb_joystick
grove_air_quality_sensor_v1_3      grove_lcd_1.2inches                grove_oled_display_128x64          grove_servo                        grove_tilt_switch
grove_button                       grove_led                          grove_piezo_vibration_sensor       grove_slide_potentiometer          grove_touch_sensor
grove_collision_sensor             grove_light_sensor_v1_2            grove_pwm_buzzer                   grove_sound_sensor                 grove_ultrasonic_ranger
grove_gesture_sensor               grove_loudness_sensor              grove_recorder_v3_0                grove_switch                       grove_water_sensor
grove_high_accuracy_temperature    grove_mech_keycap                  grove_relay                        grove_temperature_humidity_sensor  
pi@raspberrypi:~$ grove_

**Note:**If you use the I2C tool to scan the I2C address of the grove module, you may find two or more address. 0x04 is the adrress of the Grove Base Hat for Raspberry Pi .

last but not least:You need to make sure that the pin interface is connected to the wrong position. You can see the position of I2C in the figure below

here is my setup, everything seems to be well connected and in good position

in addition the grove commands are all here (unless the gps which is supposed to be supported but my priority is the three others so we’ll get to it later) but no sensor seem to work or even be detected

Hi everyone, i have tried to power the pi via a 2A 5V power supply and wire the sensor directly to the hat’s gpio pins but none of it solved the problem, any more clues ?

Hi, I’m running into the same problem, did you manage to find a solution?

Hello, i went for a totally different technical approach but with the experience I gathered since, i think that the problem may come from a loose contact between the pins and the pi even if it was screwed tight.
Start by welding the pins to the pi to ensure a proper contact.
Write me back if it worked :slight_smile: