No Module named 'Grove'

HI there,

I’m running a Grove base HAT for raspberry Pi 2 B. i have followed the installation instructions using the command

this seems to throw up some kind of failed error. it wont let me post the error but it says

i have followed these instructions several times now and the same issue keeps happening

the grove py folder structure seems to be created and all the .py files are stored in the grove folder but there is no grove.adc or other files in the grove folder .

when i run the moisture sensor .py on python it throws up an error! says no module named Grove, it clear that the grove.adc does not exist in the folder. the pi HAT is installed correctly with the sensor in the A0 port.

I’m thinking i might need to delete everything and start again? for some reason the file has not been copied but in subsequent attempts to copy it cannot as the folder already exists perhaps??

not being experienced I don’t want to do something that might make things worse!

can anyone advise a beginner like me before my poor pi gets thrown out of a window!!!

All help gratefully received!!!

this is the error message i get when i enter the curl command in terminal

glad to say I have solved my own problem here. I created a fresh OS for my Pi and started from the top. it looks like i was running an out of date OS so it wasn’t compatible!

I got a similar issue in Raspberry Pi 4 , I am using latest OS from Raspberry Pi , not sure what is causing this. Which OS image were you flashing to the Pi?